Cubox lost with 1.3 update [fixed with Roon Bridge reinstall]

I have two Auralic streamers and a cubox streamer in my house. The Auralic streamers are happy in their new Roon 1.3 environment, but the cubox that worked nicely in 1.2 is gone from my Roon configuration and no option to update it. Are any special steps required to transition the cubox to v1.3? Is there an new distribution of Roon Bridge to apply to them?

Otherwise, I’m looking forward to exploring all the new toys this release contains.


Which OS/distro is running on the Cubox?

Can you still see it in Settings > About (top tight on the settings screen)?

Have you tried power cycling the Cubox?

I have power cycled the cubox. It doesn’t show up in settings, so I can’t see what distro it’s running. I install a few months back, and it has updated with new revisions of 1.2 without any trouble, but it’s completely absent from my Settings page now.

I understand you can’t see it in Settings > Audio right now, but what Does Settings > About show?

Sorry, I misunderstood. Settings:About shows Roon Version 1.3 build 193 stable 64 bit.

I have installed an run on two different Windows 10 computers.

Under Settings:Audio it shows both computers, a receiver that supports Airplay, and the Auralic endpoints, but no cubox.

I have a second cubox that was previously configured for roon and stored away. I pulled it out and plugged it in, and it was recognised without any issues, and an update was subsequently installed and all seems to be working well. I don’t know if there was something in the installation sequence with the first one that corrupted the system or something, but at some point I’ll reload the system on the cubox that isn’t being recognised and see if that brings it back to life. I’ll be happy to pursue any diagnostics to help understand what went haywire. Another difference is that the dead cubox was a dual core version, and the working cubox is quad core. I think it’s doubtful that difference is the reason but it’s worth noting.

If you can still SSH in to the malfunctioning Cobux, check that RoonBridge is running:

sudo systemctl status roonbridge.service

and that your audio device is seen by ALSA:

sudo aplay -l

If you can’t SSH in, you’ll have a 15 minutes of installing a fresh and crispy OS of choice ahead of you. :slight_smile:

Thanks Rene,
I "putty"ed into both boxes and upgraded to system. Roon bridge still wasn’t showing on the broken box. The systemctl status command indicated something was missing in the library (sorry, I didn’t capture the message for you). I followed the instruction to download and install roonbridge, and that fixed the broken bridge up and it’s running fine now.