DAC attached to Windows is not getting recognized with ROCK Core

Roon Core Machine

ROCK 1.8 (build 918)
Windows 10 Pro 21H2 19044.1586 / 32GB RAM / 12th Gen Intel(R) Core™ i7-12700K 3.61 GHz

Networking Gear & Setup Details

Ethernet connection between AP and NUC.
Ethernet Connection between AP and Windows 10 installation.

Connected Audio Devices

  • Matrix Audio element H USB 3.0 port
  • Mainboard USB 3.0 port
  • Tower USB 3.0 port
  • ifi iDSD Black Label
  • ifi ZEN Dac Signature stack

Description of Issue

Fully up to date and working ROCK Core. Windows Roon software does not recognize any of its own ports any more. Everything worked a few days ago. Now two different DACs willl not be recognized. The Windows Roon Software recognizes the core ports and my android remote. The problem is probably with Windows or the newest update. Firewall is on private and was disabled to be sure. SMB sharing enabled. //rock/Data is reachable and ROCK over the IP as well. I was able to get the Log file, where can I upload it? Thanks for any help.

Logs: Upload files for free - Logs.zip - ufile.io

Windows updates can reset Firewalls. As a test, turn off the Windows PC firewall and see if the devices appear. If so, then you need to redo the exclusions in the firewall for Roon, RoonAppliance/RoonServer, and RAATserver.

Thank you for your answer. I disabled the firewall again. roon.exe and raatserver.exe are whitelisted.
I restarted ROCK and Windows several times. The DACs work in other Software. Exclusive mode tried disabled and enabled.

It looks like something is blocking the RAATserver on the PC (which is I am assuming at xxx.xxx.xxx.128) Roon is trying several times to connect and then giving up.

See this from the logs;

03/16 12:59:51 Trace: [raatserver] [RaatServer DESKTOP-9QFLNGJ @] connecting (attempt 5)
03/16 13:00:01 Trace: [raatserver] [RaatServer DESKTOP-9QFLNGJ @] client connection failed. Giving up

Sometimes if the network has been set to Public that can cause issues.

If you have Realtek drivers, the Windows update may have loaded a different version. Try downloading the latest from the manufacturer.

If this is a gaming machine, Video, audio production or gaming overlays have caused this issue before. Try disabling all gaming, video and audio capture software, and see if that makes a difference. For example, in one thread "Asus sonic studio caused the problem!"

btw, just a fellow user trying to help out and not official support.


As soon as I manually installed the Realtek driver the problem was gone. Thank you so much, wouldn’t have thought of that :grinning:


Glad to have helped! Enjoy the music! Wanders off to put on some myself… :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.