DAC no sound: Have to Reboot DAC after screen lock Mini Mac

Core Machine (Operating system/System info/Roon build number)
Mini Mac + Roon v1.7 b511

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Macintosh D150 USB DAC.

Description Of Issue
Login to Mini Mac (screen lock) I see connection in Roon with DAC (lower right corner) but no sound. On DAC the bitrate does no show.

Have to reboot DAC (turn of, wait 20 secs, turn on, start play Roon, yep sound again.

However, during paying when the Mac Mini goes on screen lock, the DAC keeps on playing
Also after login on Mini Mac (screen lock).
Very annoying.

Tested no result: Restart Roon, Reboot Mini Mac.
Work around: turn off DAC, wait 20 secs, turn on.

Hi @R_VDM,

Are you only experiencing this issue with the Macintosh DAC? If you play to System Output or another endpoint does the same issue occur after the screen locks?

Hi, sorry for delay.
I have tested some more.
Only the USB is problem to get started.
I use settings for the McIntosh D100, connected is the D150.

Hello @R_VDM,

When the Mac Mini goes into screen lock, does it also go into sleep mode or is it still powered on?
Have you tried a different USB cable that connects the Mac Mini to the DAC yet?
Are you using the newest McIntosh drivers?

Only screen lock, powered on 24/7.
Cable no difference.
Drivers ar standard drivers: High Sierra, version 10.13.6

Thanks for confirming @R_VDM. A few follow-up questions:

  1. When you unlock your screen, are you able to use any of your other Roon zones properly? As in - does this behavior only impact the McIntosh zone?

  2. Are you able to control the McIntosh DAC using any other applications when it’s in this state? Does iTunes work as expected?

  3. Can you please reproduce this behavior once more and let me know the exact local time + date when you notice this issue occur in Roon?

update:

  1. Yes, I am able to use other Roon zones. Seems that problem is restricted to USB.
  2. Yes, I am able to control McIntosh DAC D150 using USB and Coax input.
  3. First 3 tests (day1, 2 and 3 Mac Mini running 24/7, McIntosh audio set switched off and back on next day) no problem.
    4th day problem occurs again, McIntosh zone present on Roon, no input, no sound on McIntosh DAC D150. 17 feb 2020; 16:02 hr. local time Netherlands.

If I log-in on Mini Mac first and then turn on the McIntosh set there seems no problem.
After powering up D150 just wait for D150 to show up in Roon and start play.

Looks like the D150 goes direct in hibernation if there is no USB signal and does not wake up after log in Mini Mac. After log in on Mini Mac Roon shows the D150 zone/connection and Roon will play but signal does not show on D150 display and there is no sound from D150. Power D150 off, wait 20 secs and power on again is the only way to get music started.

Hope that this info wil help to get the picture. Maybe it is a D150 problem…
Thank you for looking in to this.

Hi @R_VDM,

Thanks for letting me know that additional information.

I have activated diagnostics mode for your Core and what this action does is automatically upload a log-set to our servers next time it’s active. Once this report is received I will discuss with the technical team to see if there are any further clues in logs regarding this behavior.

update 20-Feb-2020
16:07 start Roon > stolling: adding music to library (connected, scanning now…), wait till ready
16:12 start play > no signal on D150
16:17 quit Roon, start Audirvana > no signal on D150 !, quit Audirvana
16:34 change USB port Mac Mini
16:38 start Roon > menu; audio; enable McIntosh, reboot D150
16:45 playing Roon and signal on D150
will be continued…

1 Like

update
21-Feb-2020, 11:33 Boot MacMini, Startup Roon, after scanning, Start play Roon; all ok.
21-Feb-2020, 18:42 wake up/login MacMini, Start Paly Roon: all ok.
22-Feb-2020, 13:54 wake up/login MacMini, Start Paly Roon: all ok.
23-Feb-2020, 17:55 wake up/login MacMini, Start Paly Roon: all ok.

Looks like changing USB port (same cable on other port) on MacMini had an effect…
Or something else changed, like update Roon or update MacOS.
Nothing else changed in my set up and settings.
I will continue testen en registering

1 Like

Thanks for the update @R_VDM,

Do let me know if the behavior still remains stable with the other USB port in use.

Issue occurred again but only few times.
I stopped testing.
Routine and workaround:
Power-up / wake-up / log-in MacMini first before power up MacIntosh set.

Problem still occurs. USB connection dead after > 4 hours. Solution found:
With the release of the OS X Mountain Lion v10.8.2 supplemental updates, a new feature was introduced to enter SAFE sleep after 4 hours of the computer being connected to AC power. This is an effort to comply with the European Energy Standards. This will occur if there is no wireless, ethernet or device activity. Settings can be changed using Terminal app (Finder/Go/Utilities/Terminal)

  1. When in Terminal application type to show current configuration sleep/hibernate/etc:
    pmset -g

  2. Change your standbydelay to 86400. Is number of seconds in 24 hours. Here’s the command:
    sudo pmset -a standbydelay 86400

  3. Change autopoweroffdelay to 86400. Here’s the command:
    sudo pmset -a autopoweroffdelay 86400

  4. At last but not least change autopoweroff to 0. Here’s the command:
    sudo pmset -a autopoweroff 0

Reboot system and check your new settings by command: pmset -g
Since I changed these settings no more going into Safe sleep!
No more losing USB connection between Mac and external DAC / AMP.

1 Like

Hi @R_VDM,

Glad to hear that changing the power settings helped resolve this issue!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.