DAC not listed as "Connected to Roon Core" on QNAP

When aplay can see the device, Roon will also. I think we’ve just proven that this problem is lower-level than Roon.

The fact that it’s in procfs is a good sign that the kernel can initialize the device at some level.

To check if the device is being used, you could run speaker-test -D hw:1,0 -c 2 -r 44100 -F S32_LE and see if you can make sound come out of it.

If it works, that tells us one thing. If not, then it should print an error that either indicates the device is in use, or maybe tells us something else.

Just like with aplay, if speaker-test can’t be made to work, Roon won’t work either.

Ideally, you would be running all of these commands with the same account/permissions as Roon’s environment on the NAS.

Hi Brian,

here’s the output of the speaker-test command:

speaker-test 1.1.0

Playback device is hw:1,0
Stream parameters are 44100Hz, S32_LE, 2 channels
Using 16 octaves of pink noise
ALSA lib pcm_hw.c:1713:(_snd_pcm_hw_open) Invalid value for card
Playback open error: -2,No such file or directory

I don’t seem to have the soundcore kernel module. Could that be the problem of Alsa not detecting the USB device ?

lsmod | grep snd
snd_usb_caiaq 34719 0 - Live 0xffffffffa0192000
snd_usb_audio 91051 0 - Live 0xffffffffa01b7000
snd_usbmidi_lib 17620 1 snd_usb_audio, Live 0xffffffffa00fb000
snd_hwdep 5669 1 snd_usb_audio, Live 0xffffffffa00c2000
snd_seq_midi 4656 0 - Live 0xffffffffa00bd000
snd_rawmidi 17385 3 snd_usb_caiaq,snd_usbmidi_lib,snd_seq_midi, Live 0xffffffffa00b7000
usbcore 195372 13 8192cu,btusb,uvcvideo,snd_usb_caiaq,snd_usb_audio,snd_usbmidi_lib,xhci_hcd,usblp,usbhid,usb_storage,uhci_hcd,ehci_hcd, Live 0xffffffffa0009000

Chris,
No soundcore.ko file under /sys/module… But on yours neither, apparently so this might not be the problem. What does lsmod | grep snd tell on your system ?

Cheers

That’s why I deleted my previous post again… :wink:

[~] # lsmod | grep "snd"
snd_usb_caiaq          39490  0
snd_usb_audio         140372  0
snd_usbmidi_lib        21220  1 snd_usb_audio
snd_seq_midi            5606  0
snd_rawmidi            18981  3 snd_usb_caiaq,snd_usbmidi_lib,snd_seq_midi
[~] #

So no soundcore module apparently… Not sure then why Alsa does not detect my card…
Frustrating

Was your USB audio device plugged when you issued the lsmod command ?

@Christian_Chateauvie, why did you delete your comment saying MusicStation is working–is it not actually working? (Just making sure we’re thinking about this clearly).

Also, on the off-chance that you can do this test–do you have another Linux machine that you could plug the DAC into and see if it works with Roon Bridge?

Especially if MusicStation is not working, this could be an issue between the DAC + Linux instead of the DAC + QNAP. Just helps isolate the problem further.

MusicStation is working - but I suspect it is using OSS and not Alsa. This is why I’ve deleted my post.
I’ve connected the DAC to another Linux box and it is probably recognized by ALSA (aplay -l lists the device).
Unfortunately this other linux box is not supported by Roon (it is a 32-bit kernel)

So this must be something about the QNAP kernel or something. I haven’t tried connecting another USB device to it because I don’t have any right now - but will test further

Frankly I am a bit desperate now. Not certain if I should sell my QNAP for another model (do you know if things might get better on a TS-469L, which supports QTS 4.3.3) or if I should better switch to Synology - your advice would be welcome.

PS I tried to downgrade the firmware to 4.2.0, to no avail.

The aplay command does not work on my QNAP either.

I could make the output of the aplay command work after installing QNAP’s HybridDesk Station and entering:

[~] # aplay -L
ALSA lib control.c:953:(snd_ctl_open_noupdate) Invalid CTL hw:0
[~] # chroot $(getcfg hd_station install_path -f /etc/config/qpkg.conf) /bin/bash
root@Roon:~# aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
hdmi:CARD=HDMI,DEV=0
    HDA Intel HDMI, HDMI 0
    HDMI Audio Output
hdmi:CARD=HDMI,DEV=1
    HDA Intel HDMI, HDMI 1
    HDMI Audio Output
hdmi:CARD=HDMI,DEV=2
    HDA Intel HDMI, HDMI 2
    HDMI Audio Output
dmix:CARD=HDMI,DEV=3
    HDA Intel HDMI, HDMI 0
    Direct sample mixing device
dmix:CARD=HDMI,DEV=7
    HDA Intel HDMI, HDMI 1
    Direct sample mixing device
dmix:CARD=HDMI,DEV=8
    HDA Intel HDMI, HDMI 2
    Direct sample mixing device
dsnoop:CARD=HDMI,DEV=3
    HDA Intel HDMI, HDMI 0
    Direct sample snooping device
dsnoop:CARD=HDMI,DEV=7
    HDA Intel HDMI, HDMI 1
    Direct sample snooping device
dsnoop:CARD=HDMI,DEV=8
    HDA Intel HDMI, HDMI 2
    Direct sample snooping device
hw:CARD=HDMI,DEV=3
    HDA Intel HDMI, HDMI 0
    Direct hardware device without any conversions
hw:CARD=HDMI,DEV=7
    HDA Intel HDMI, HDMI 1
    Direct hardware device without any conversions
hw:CARD=HDMI,DEV=8
    HDA Intel HDMI, HDMI 2
    Direct hardware device without any conversions
plughw:CARD=HDMI,DEV=3
    HDA Intel HDMI, HDMI 0
    Hardware device with all software conversions
plughw:CARD=HDMI,DEV=7
    HDA Intel HDMI, HDMI 1
    Hardware device with all software conversions
plughw:CARD=HDMI,DEV=8
    HDA Intel HDMI, HDMI 2
    Hardware device with all software conversions
root@Roon:~# exit
exit
[~] #

I don’t see this app being available in my QNAP app center.
But anyways.
Things work on your QNAP in spite of alsa -l not working
so where do you think the problem can be ? Brian seemed to indicate that Roon wouldn’t detect if aplay doesn’t …

The HybridDesk installation has to be done in the Control Panel > Applications > HybridDesk Station. But I am unsure if it exists for all models…

Not on mine at least. But this is not a prereq for Roon, right ?

So could the problem be coming from Roon and not from my NAS ? I suppose Roon detects your devices even whe you don’t have HybridDesk and the alsa command does not work ?..

No, it is not a requirement for Roon…

Btw does it make sense to install RoonBridge on the NAS ? I guess if RoonCore does not detect same will RoonBridge… but perhaps I am wrong

With RoonBridge you should have the same outcome regarding your DAC as with RoonServer.

I prefer QNAP over Synology, personally.

I’d sooner buy a $10-40 SoC device (Raspberry Pi, FriendlyARM, etc) and install Roon Bridge on it than sell/rebuy a NAS over something like this. That’s by far the most common scenario among our users for doing audio on Linux–much more common than plugging audio devices straight into a NAS–most people like to keep their NAS far away from where they are listening because of fans/noise/heat/etc.

Roon uses the same mechanism for enumerating devices as aplay -l, but the environment where Roon runs is a bit different from what I’d imagine a shell looks like on these devices. At least, the Roon QPKG includes an ALSA library which is not normally installed on the NAS.

Is there any chance that the ALSA library in the QPKG is newer than the kernel-side ALSA support on this particular device or something like that? Just looking for differences…

Interesting idea… but it would require me to purchase and power up yet another device. Will keep this idea as a ‘plan B’ if everything else fails…

On my NAS the ALSA driver version (returned by ‘cat /proc/asound/version’ ) is 1.0.25. Perhaps this explains it ?

Chris, what version of Alsa libs does the QPKG include ?

Thanks again to you two for your patience and efforts

Am giving up on this. Purchased a QNAP TS-469L instead on which Roon immediately detected the USB DAC. So my conclusion is that there is a problem either with the QNAP TS-459ProII board itself or with QTS 4.2.0 thru 4.2.6 - preventing the Alsa setup from working properly with Roon. It may also be due to the Alsa libs embedded in the Roon installer packager for QNAP.
Will do a final test on the QNAP TS459ProII by plugging another USB audio device in a few days, but for those considering running Roon core on TS459Pro2, the conclusion is: Roon works but fails at detecting USB audio devices connected to the NAS.

To close the thread here… I have tried connecting a USB headset to the QNAP TS459Pro2 but same result - it does not get recognized by Roon.