DAC not recognized on M1 Mac

Core machine: MacBook PRO 10.15.x, ROON 1.18
Roon-Endpoint; several, including my MB-PRO M1, 11.2.3
With the MB-Endpoint, I encountered exactly the same problem: it will nog recognize my DACs (tried several, both direct trhough USB-C and via CalDigit USB-C-hub).
Followed your lead and disconnected the M1 MB-Pro from the central core and used it instead as the new core. The M1 MB-Pro recognised both the DACs trough USB-C as well as the Calldigit. Hurrah.
But after I switched back to the old core (where my music sits, obviously), all DACs as well as the Calldigit where gone. I tried the RAAT-thing, that didn’t work either. I’m desparate.

Hi @jean_coumans

On the new M1 Mac did you use anything like Time Machine or Migration Assistant to move everything from one device to the other?

Have you tried reinstalling Roon on the M1? You’ll want to make sure you also remove the database and settings — See instructions below:

  • IMPORTANT - Only do this on the M1 remote, not the MacBook Pro Core machine. If you do this on the Core, you’ll have to restore a backup to recover your database.
  • Stop Roon on this device
  • Navigate to your Roon Database Location on the M1
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

I’m sorry: I followed your instructions, but nothing changed.

Hi @jean_coumans, can you share some screenshots of what you’re seeing in Settings > Audio?


. 'Dezee MAC being this Mac, the Macbook Pro with M1-chipset.
And some screenshots from my M1-audiosettings, just to get an idea of what the M1 has avaliable.

I directly plugged in a USB-C DAC-Dongle, the FX-Audio TP-i01. Macbook recognises this, but Roon doesn’t: