DAC not showing correct resolution[SOLVED]

MY LUXMAN DAC DA 06 only shows 48k resolution regardless what resolution is being sent .I have this same problem also from TIDAL. Now when I run TIDAL thru a MAC MINI I don’t have this issue. This issue is based on WINDOWS 8 . I also have JRIVER 19 INSTALLED and it does not have this issue on this particular lap top running WINIDOWS 8. Again to recap, when using this lap top, running either TIDAL, or ROON, only 48k shows up on my DAC readout, regardless of resolution being sent to it (44.1, 88 192 ETC) yet when same material is sent thru JRIVER 19 (OR 20, but my 20 trial ended) the DAC shows that it is indeed receiving what is being sent (44.1 88 192, ). I have enabled the EXCLUSIVE MODE, and while that does seem to offer better sound, the resolution showing up on the LUXMAN is still only 48, regardless what is being sent to it. Again, when using JRIVER this isn’t an issue.
Finally I see JRIVER 20 is showing up on the AUDIO setup section of ROON . Why is this even there? I have it enabled but I am not following why it is even there. Does this mean that when I use JRIVER, with ROON running in the background that I will be getting better sound than I would if I just used JRIVER ALONE?.

MY LUXMAN DAC DA 06 only shows 48k resolution regardless what resolution is being sent .I have this same problem also from TIDAL.

In Roon, try enabling the Use Exlusive Mode" checkbox next to your audio device on the audio settings screen.

By default, Roon operates in “Shared Mode”–which means it sends its audio through a virtual mixer managed by your operating system. This allows multiple applications to generate sound at the same time and have them mixed together. This is a nice user-friendly default for many people who don’t have nice DACs like yours, but is probably not the right choice for your setup.

By enabling “Exclusive Mode”, you’re telling Roon that you want it to take over control of the hardware device as fully as possible. This will bypass the OS mixer and should sync up the sample rate of the content with the sample rate on the hardware. Among other things, this is generally required to enable bit perfect output.

I’m pretty sure that JRiver enables “Exclusive Mode” by default, and that the TIDAL app does not support exclusive mode at all, but these are just my guesses about other companies’ products.

Let us know how this goes–if this doesn’t work out for you, I’m sure we’ll be able to find a way to make this work.

Now when I run TIDAL thru a MAC MINI I don’t have this issue.

Apple’s “Shared Mode” mixer has slightly different behavior than Windows–I think that may be helping you here by accident.

I believe (Don’t quote me on this) that if you’re only playing one stream at a time on a mac, depending on the particular audio chip in your mac, that it may sometimes switch the sample rate of the OS mixer to match the stream’s native sample rate.

The Windows “Shared Mode” mixer always runs at a fixed rate–you can select this rate in control panel.

Finally I see JRIVER 20 is showing up on the AUDIO setup section of ROON . Why is this even there? I have it enabled but I am not following why it is even there. Does this mean that when I use JRIVER, with ROON running in the background that I will be getting better sound than I would if I just used JRIVER ALONE?.

JRiver 20 ships with a virtual sound card driver that seems to be enabled by default (I found this confusing, too, but it’s not up to us). This creates a fake “audio device” in the Windows device list. Roon detects the audio devices available on your machine and displays them in the app. Since JRiver has injected their “device” into the list, it is showing up in Roon.

There’s nothing special going on here between Roon and JRiver. If you don’t want to route Roon’s audio output through JRiver, simply avoid enabling the JRiver audio device in Roon.

Sorry, I just re-read your post and I see that you may have already tried enabling Exclusive mode.

@kevin, can you help @MRJAZZ send us some logs that include him playing some content and experiencing this failure?

I can report the same issue as MrJazz, the icon above the playback graph states it is downsampling 24/96 to 16/48. JRiver 20 works fine. DAC is a Schiit Gungnir, if that makes any difference.

It is probably DAC dependent. Unfortunately, we don’t have a Schiit Gungnir in our QA arsenal :frowning:

My guess is: we’re trying to open the DAC at 24/96 and it’s saying “no” because it expects something different (32/96 probably), then Roon probes “easier” formats by downsampling/cutting bit-depth until it accepts what we give it. I bet JRiver is trying 32bit first.

Clearly this needs some work. @kevin will help you get logs to us, then we can go from there. I’m sure we can get this working.

@MRJAZZ and @toddrhodes, pm’ing you both shortly with instructions for how to send logs. Thanks for your patience!

Same problem also for me.
In my Windows PC I have a Pink Faun Bridge card connected to my Pink Faun 2.32 DAC. If i don’t set the exclusive mode all file go out at 192 Mhz., I think this is for my setup of the Pink Faun Bridge in Windows Audio:

If i set the Exclusive Mode in Roon the 44,1’s files are played at 44,1, but all files above 44,1 (96 - 192) are played at 48.0 kHz.

Hi, I have a question about bitrates, too.

I’m using Roon in direct mode with the Cambridge DacMagic 100.

I have many hi-res files. When playing from Audirvana, the DAC shows the correct bitrate (96, 192), but in Roon it is always showing 48.

Am I missing something?



My main library is on my iMac. I’m using my MacBook as the client (wifi) and it gets hooked up to my NAD 390DD (goes up to 24/192). Changing zones and having the Roon client find the NAD was gloriously simple and I get sound, but 24/96 and above recordings only show up as either 44.1 or 48 in the NAD window showing the recording info. Maybe I’m doing something wrong?

You’re connected to the DAC via USB, right?

I am. Sorry for not saying that before

Cool. This is on our end. We’re working on it.

1 Like

Hi, when I played 24/96kHz music via USB to my Devialet, Roon downsample it to 48kHz claimed adjusting for hardware compatibility. Playing 24/192kHz, there’s no downsampling. Is there a reason why and/or way to adjust this parameter?

I’m using Roon on a Mac Mini.

Hey @hk6230, we’re aware of the issue and this will be fixed in the next build, sorry about that!

EDIT: apologies @hk6230, I misspoke, this fix just missed the build that’s currently being tested for release, it will be rolled out soon after.

Thanks. You guys are fantastic.

Hi All. Remembering some issues with he way Macs handle 3rd party programs and audio output I decided to go into Utilities>Audio MIDI Setup>DAC (whatever the name of your DAC is) and make sure that the highest format is chosen. This seems to have cured the issue of my particular DAC only showing playback at 44.1 or 48 kHz. My DAC plays files up to 24/192 and choosing a variety of files the output my DAC shows is now correct after having made these changes. Try this and see if it works for anyone else and to the Roon people, do you think it could be that easy?

@digitalized are you using “Exclusive Mode” within Roon?

If so, then I’m surprised that that setting has an effect.

If not, then your audio is going through the OS mixer anyways, and though this setting might fix the output rate, it isn’t necessarily giving you bit perfect output.

The bug that I’m fixing is really only for exclusive mode configurations. When Roon tries to send audio to a device and the device won’t accept the native format of the audio, Roon has to figure out a way to adjust the stream for compatibility. Currently Roon solves compatibility issues by first reducing sample rate, then reducing bit depth. This works fine for the small mountain of DACs in our test rig, since they all take 24bit natively so the bit-depth reduction never comes into play, but you guys have discovered that there are some DACs out there where this scheme is no good.

Assume for a second that you’re trying to play back 96k/24bit audio and getting 48k/16bit on the output side–at least one of the logs I analyzed looked like that. The exact problems you’re experiencing might be slightly different, but they all look like 24/2x or 24/4x -> 16/1x.

It looks like some devices will accept 96k/32bit or 96k/16bit natively, but refuse to accept 96k/24bit. Because we’re reducing sample rate first right now, we start by downsampling to 48k/24bit then ask the device again. When that doesn’t work, we try 48k/16bit and the DAC says “ok” and we run with it.

This is bad. The right thing to do would is to reformat the 96k/24bit data as 96k/32bit so we can make the device happy without doing unnecessary DSP. I’m currently in the midst of re-arranging this so that it handles these devices well.

I should be done with this work before I sleep tonight–as soon as it’s done, we’ll give it a couple of days in QA to make sure that I didn’t accidentally break something else while doing this stuff, then push it out to you guys.

Thanks for the patience!

1 Like

Thanks for the detailed explanation, Brian. I am using exclusive mode in my Roon settings. I look forward to getting a real fix sometime next week, hopefully.

I am having an issue with Roon and PureMusic.
When I select Exclusive Mode in Roon, the sound via PureMusic is distorted. When I uncheck Exclusive Mode in Roon, PM only detects 44.1 material, but Roon says its 88, 96 or whatever I play. From PMR I send the sound to a HiFaceTwo (max 192 kHz) converter

Best KnockKnock

just downloaded the trial- not sure if i have this all setup correctly? system consists of a mac mini 2012 1tb spinning hd connected to an audiophilleo usb/spdif converter and going into the coax input on the rega dac. i have read these posts and read that roon is downsampling my audio to 48.1 on the high rez flac files. is this accurate? i also have pure music on my mac but have not ab room with it yet and also not sure if the two should be running together? i am using a macbook at my listening seat to remotely control room so i do not have to keep the monitor on? audio is my primary thing so want to know if i am getting the full zoot audio experience i was getting with audirvana and pure music? help and thoughts appreciated! i really like the software and it would be a no brainer if i can the full hi rez audio capability without the audio signal being down sampled-this defeats the purpose of my system. thanks! Gary