DAC not showing correct resolution[SOLVED]

Double check that your are not using System output. This is the output of your OS and will be at a fixed rate like 48k.

In the Roon settings for your USB device you should have it set for EXCLUSIVE? Then it will be using a bit perfect signal so you will get whatever resolution and rate your file is.

Hope that help

And direct mode is promised in the next build.

Yup I was using system output in addition to my exclusive dac and the files were playing at what resolution the system output was set to. I disabled system output and just have my dac set to exclusive mode and it seems to be recognizing the native resolution of whatever the file is. Seems good to go now-big improvement! Seems to be on par if not maybe a bit better than pure music and audirvana-

Question? Should pure music be running with roon or are they mutually exclusive?

Lastly-what is direct mode and how will that improve what is onboard now?

As you can tell I am a huge audiophile-great product!!

I know the Roon guys are too so they will really appreciate knowing that it sounds good.

@Egres – “Direct mode” is an Audirvana technique to avoid CoreAudio, and the trouble it causes is probably not worth the quality is buys (if any). That said, we are looking into it, but this was not a deliverable on our roadmap yet.

The next build is adding quite a few audio features, like integer mode and sample rate limiting, but not this notion of skipping to the HAL (Direct Mode).

ASIO driver is probably the preferred way to do that in our opinion, as it would give you the most minimal interaction, and let the interaction be dictated by the hardware vendor. This is not coming in this next build, but will be coming soon after. No date yet, but hopefully within a few weeks.

@gary4264 – The exclusive mode you use now is how applications are meant to talk directly to the audio endpoint , and negotiate all terms with it. The OS mixer and layers stay out of the way, allowing for a bit perfect stream directly to the endpoint.

Direct Mode try to bypass the OS mixer in a different manner.

Integer Mode is an interesting one, only for OSX 10.9+ where they reintroduced the feature. It tells CoreAudio to do some processing without a (lossless) conversion between floating point and integers. Because this is lossless (for 16bit and 24bit), the bits going to the endpoint are identical. However, it gains some efficiency in the process, and thus could have an audible impact by reducing electrical noise created by your system.

I don’t have a strong opinion as I don’t use it, but I’ve seen a lot of people claim that Roon and Pure Music are exclusive to each other. No need to have both. Im sure there are others that disagree. I don’t see why you’d want both.

My bad. I meant interger mode instead of direct mode. Maybe wishful thinking!

@Egres – I have been using integer mode in Roon all day today :smile:

Wonder if there was any update to this thread. I also use a Luxman DA-06 and only can play 48k no matter what the source sample rate is.

Additionally, I can only use the System Output in the audio settings section. If I try to use the Luxman DA-06, even with exclusive mode, I just get error that there is no audio device connected.

Thanks

It started working for me. I had to make sure I actually typed in Luxman and did not leave the device set to unnamed in audio settings. Then playback not only started but I got correct sample rate playing back through Luxman DA-06.

Tried to upload a picture but was not able to do so as a new member.

just downloaded the trial- not sure if i have this all setup correctly? system consists of a mac mini 2012 1tb spinning hd connected to an audiophilleo usb/spdif converter and going into the coax input on the rega dac. i have read these posts and read that roon is downsampling my audio to 48.1 on the high rez flac files. is this accurate? i also have pure music on my mac but have not ab room with it yet and also not sure if the two should be running together? i am using a macbook at my listening seat to remotely control room so i do not have to keep the monitor on? audio is my primary thing so want to know if i am getting the full zoot audio experience i was getting with audirvana and pure music? help and thoughts appreciated! i really like the software and it would be a no brainer if i can the full hi rez audio capability without the audio signal being down sampled-this defeats the purpose of my system. thanks! Gary

@gary4264 - I run a similar setup with a 2012 Mac Mini running Roon (Core) connected via USB to my DAC. I run the Mac Mini headless, so no need to keep the monitor turned on the Mac Mini.

When running Roon I would not have Pure Music running at the same time ( at least I wouldn’t ).

I too use a Macbook with Roon installed to remotely control Roon playback on the Mac Mini.

If you want to check the audio playback quality, all you need to do is click the little dot (light) you will see to the right of the track you have playing back in the transport (see picture ), that dot (light)will be yellow, green or purple. Here is a link that describes what the dot color indicates.

1 Like

The “next build” is here!

Please let us know how it goes.

So far so good. Integer mode working well and I like the new interface improvements.You guys are really making good on your promises to keep improving things, thank you. Looking forward to DSD in the next release.

Gary are you running the Mac mini headless?
If you are how do you select what to play?
Thanks.
Rob.

Any luck with this?

I just started a Roon trisal and see the literature still says 24 bit files no 32 bit.

I use a Geekout dac wich can handle 23/384 and dsd…

Hi, just download the trial, when I played 24/96kHz music via USB to my Audionet DNC by Macbook Pro, Roon downsample it to 48kHz. When play 24/192kHz, there’s no downsampling.
I can see the source is 24/96kHz in Roon, and I try to turn on/of Integer mode in Ronn but it’s same, downsample to 48kHz
How I can fix it here?

Thanks!

Can you give us some more information about your setup, as described here?

Thanks!

4 posts were split to a new topic: Roon maxing out at 48khz [Solved]