DAC settings not sticking [Ticket Open]


I have a RPi Roipeee feeding USB to a Audiolab M-DAC

I can see device settings ok, when I set the Volume Control to Device Settings and save all looks ok but when I go to adjust the volume it’s still set as Fixed despite changing it

Any thoughts


A post was split to a new topic: Aries G2 Volume Control

Ah ah

Thought it was me being daft



Hello @Mike_O_Neill,

Thank you for the report. I was able to reproduce this behavior on Linux with a few USB DACs. I filled a bug report with the development team.

In the interim, can you try these steps to get things working for you until we’re able to resolve this issue

  1. Open Device Setup for the zone and click “Load Defaults”
  2. Save whatever the ‘default’ settings are
  3. Reopen Device Setup and set your desired volume control scheme
  4. Click save

Using these steps, I was able to save my desired Volume Control setting.


Keep pressing the buttons …

However it worked, I must have not tried that combo

Thanks agin