DacMagic 100 not playing back at 192/24

I use an iMac for my core and play often from from MBP using a DacMagic 100 connected directly to the MBP or via an OWC USB-C dock. When I play 192k/24 content (core library, or Qobuz) it is getting downsampled to 96k. When I check Audio MIDI Setup the DacMagic is set for 192,000 Hz 24-bit, and the 192k indicator light is illuminated on the DacMagic. In roon the signal path indicates sample rate conversion from 192k to 96k. I’ve tried with exclusive mode on and off, but when I use exclusive mode the only difference is that the indicator light changes over to 96k when on and there is no difference in the signal path. When powering on the DacMagic I hold the source button when coming out of standby to set the unit to USB Class 2 mode so the 192k should be available. I did notice that the default audio settings show 32-bit support, but I’ve tried that with both 32-bit and 24-bit (the DacMagic max). What setup can I try to get to a lossless signal path?

Do you have the Class 2 USB driver installed?

EDIT: My bad, apparently MacOS doesn’t need it…