DACs pops with unimplemented mute if sync is lost - possible RopieeeXL output?

Hi all,

Now after having used my RopieeeXL device as a Roon endpoint with “the darn” Audiophonics AES HAT, there are particulary one thing that bothers me.

Playing with Roon: at every change of format, my JBL monitors respons is a popping sound as from an electrical discharge. At times it sounds like it will ruin my speakers.

I have ways to beleive that its’ root cause is a sloppy implemented DAC in the monitor, not engaging the mute function the moment sync is lost or returns, preventing this highly annoying and possible damaging pops.

Having said that, I admit the responsibility is JBL’s. BUT, is there any way Ropieee can be equipped with an option (on or off choice in the meny) to play digital black? If there is anyone not knowing the term, it derives from master engineers monitors turning black when the signal is gone but the output plays on with just a sync keeping the DAC input open. In my proposal, it should be the latest track format sync that simply allows to go on.

Playing Spotify from a computer to this RopieeeXL device, means having sync drops between every track and it will not cure this to ask Spotify to output prolonged sync to “preventing pops from certain DAC’s”. It somehow does not take effect from the RPI + HAT output. So every darn track shift it pops as hell in the speakers, and twice, when the sync is lost and when it returns again.

In Roon it happens only when there is a format change, it seems the Roon software plays digital black, or that Ropieee itself is compatible with Roon on another level. I have managed to completely cure the problem by setting Roon to always output 24/96 whatever source format. This measure keeps the JBL synced also during the pause between tracks, but not when stopping playback. After a few seconds the sync drops and it pops.

Now, if Ropieee would have an extra treat to keep outputing digital black, these pops would not occur. Possibly same sync format as latest track? There are no format changes from Spotify and by setting Roon to, also for sound quality, upsampling, it would mean no pops between tracks. Further it would mean that the listener could perhaps be given a space of perhaps 30 seconds to search for new tracks/albums? Or the optional menu choice could include the digital black silent output duration?

How about this? Would this be possible to implement (and be an option to turn on or of) for us sorry asses with sloppy built but decent sounding DAC’s or in my case monitors?

1 Like


There’s no way RoPieee can ‘intervene’ while playing via Roon.

However, Roon has a setting for issues like these: Resync Delay.
This delay is applied (amongst others) when there’s a change in sample rate as there are more DAC’s that have an issue with that.

Have you tried that?


1 Like

I do not mean to intervene. I simply suggesting keeping digital black output even if source is turning silent for a while, e.g. a paus between tracks. I have fixed the problem by setting all source files at the same output bitrate and sample rate 24/94. What is NOT working is the short paus between tracks in Spotify. Further RopieeeXL does not seem to react on the command to keep playing digital black, an optional feature in Spotify app to prevent losing sync in DAC’s like mine in pauses between tracks. But playing through the endpoint, this command/optional setting seems to not working. No matter what delay I choose in Spotify, the pops remains.

I will however check the sync delay option, thanks :slight_smile:

Now, have I managed to explain myself better? I’ll be happy to explain further