Daily Mixes updating on every app launch

I’m seeing my daily mixes update ever time I launch Roon on any platform. My clients and core are all on 1223 / production.

I recently moved my core from Docker on Synology to Server on Ubuntu. Everything other than this is working fine. Any thoughts? Is anyone else seeing this?

I’ve confirmed that the date/time/timezone are all correct on the machine. Also, rebooting doesn’t impact the behavior.

[Edit : Relocating to “Support”. This appears to be a bug that has been confirmed by at least three people].

I observe the same behavior with 1223, without any changes to the configuration.

1 Like

Now it’s an “Instant Mixes”…

After restarting the MacBook Pro Roon remote, I’m getting

The same thing is happening with my iPhone. Which gives me completely different daily mixes compared to my MacBook. And the mixes change after every Roon remote restart on my phone as well.

This wasn’t the case with previous Roon versions. Same dailies on both devices and they’ve stayed the same all day as well. It is as @Gianni describes. “Instants Mixes”.

My guess is that the Roon software has discovered time traveling. Each start of a remote apparently equals a new day :upside_down_face:

1 Like

Thank you both for confirming this. It’s pretty clearly a regression in the latest release.

I prefer the “daily” version of the feature to the “instant” version :slight_smile:

1 Like

Moved to support.

Daily mixes appear to be working correctly for me again.

I relocated my core which involved a power cycle. When it came back online, I was logged out of both Tidal and Qobuz. It’s possible that this wasn’t caused by the power cycle - could have been logged out prior to that but I know they were logged in last night.

With neither Tidal nor Qobuz logged in, no Daily Mixes showed up at all - the section was missing from Home. I logged back into both services, Daily Mixes re-appeared. They are no longer updating on every app launch or refresh.

I don’t know if the change was done server side or if some combination of log out / log in fixed it, but it does seem fixed.

I’ve just restarted Roon here, and the daily mixes remain the same.

I did restart the core yesterday as it had eaten up all available RAM on my Lenovo laptop again, making Roon unresponsive to use. RoonServer seems to eat nearly 14 gb of the 16 gb of RAM after a few days, requiring a reboot to get everything working again on Linux.

By this, do you mean that they are the same after the reboot as they were prior to the reboot? In other words, is it fixed for you?

I wonder why some people are reporting memory leaks and others aren’t. My core is on a NUC running Ubuntu 20.04 and I don’t think I’m seeing one.

Problem solved for me too (without any reboot of the core).

1 Like

Well the issue is back again. On both my MacBook Pro and iPhone.

I’ve done a Core reboot as the Linux distro it is running on had a bunch of updates including a new kernel version.

Now it’s back to Las Vegas mode of what to expect when it comes to daily mixes.

I’m getting this too. Everything’s running ‘earlyaccess’ but iPhone, iPad and Windows Remotes all show different Daily Mixes on every app restart, as does ARC.
I’ve restarted the server software and the server itself, but no change.


It’s occurring again for me as well.

Same here…

It is preferable that daily mixes stay unchanged for a day.

But adding a “randomize” button, which would reset the daily mixes on demand, could be a fun feature.


I am not getting any daily mixes at all. I’ve rebooted the core (ROCK) and remote.
Build 1234

I am also suddenly not seeing daily mixes. Linux sonictransport music server Roon build 1234. Was working perfectly until a few hours ago. I rebooted the server, but mixes have not reappeared…

Any ideas? Is ROON working on this problem?

Daily mixes have also completely disappeared for me.

As far as I know, Roon hasn’t acknowledged any of the reported issues with Daily Mixes.

I imagine they are aware of the problem… at least we hope so

daily mixes gone for me too running running ROCK on my core.
same on windows & android apps.