Dark Mode Crash - LG V30

I run a roon core on an Asustor AS55304T NAS, running the latest NAS and roon software available for it. I started using roon a few days ago and switched to the dark mode on my LG V30 (latest OS). It worked for hours and then was shut down for the night. Next day, I tried getting some music going, and the app on the phone would show “roon” and then crash, every time. I tried numerous times, rebooted the phone, etc. to no avail. I ended up having to uninstall the app, re-install, and leave it in the light theme for it to work. Any re-installations would crash when switched to dark theme.


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue


Hi @Brian_Redpath,

When did this first happen? What version of Roon on Android did this start happening for?

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Thanks for the quick response. The problem hasn’t happened again until tonight. It happened at 5:05 pm, and I haven’t been able to get my Android app running again. It is showing version 1.7 (build 521) stable.

One other thing that I just noticed, is that Roon closes, right after showing that it is looking for the roon core. However, it doesn’t seem to completely crash, as it still shows as an open app (albeit a black screen in the background, see screenshot) when I go to switch to another app. I rarely have more than 4 apps open in the background at one time.

Hi @Brian_Redpath,

It sounds like it was working for a while — Were you using the dark theme this entire time?

If you uninstall and reinstall do things work again for some time, even using the dark theme?

Have you noticed any patterns here? Does this seem to happen after selecting an album with no artwork perhaps?

It was working for quite some time, all in dark theme. I think I’ve nailed it down to selecting a folder on my NAS that contains a mix of high-res music files. It seems to crash after opening the folder, and then require a complete uninstall and re-installation before it will work again.

In fact, it’s when I select the 2L album from the NAS using my Android phone. The iPad mini 2 will allow me to go into the same album without the app crashing. The crash also happened on the Android while using the light theme.

Thanks for the clarification, @Brian_Redpath.

Does this album have artwork associated with it?

No. The album doesn’t appear to have any artwork associated. It is a sample collection of 96/24 files from various artists and albums, all in one folder/album.
FYI, my trial period has ended, and I won’t be signing up for a subscription at this time, so I will be unable to do any more testing on this. It’s nothing to do with my support experience. The software just isn’t enough value to me at this time.

Thanks for the details, @Brian_Redpath! It sounds like this is an issue that we are currently aware of related to some Android devices crashing when opening an album that doesn’t have artwork. Our team is working on a fix for this which we hope to release in the near future.


We’ve released a new update, Roon 1.7 Build 528, which contains improvements that we believe will help with the issues you are experiencing here. Please see our release notes below:

The Team At Roon Labs