Database backup error

I’ve got a QNAP TS251 running my Roon core and I’m trying to back up to and external drive that is attached to my Windows 10 system through the network. The connection has been established for two years but recently it has been lost. Within Roon it shows as a destination for the backups but won’t connect. I deleted the destination and tried to re-establish it and when I do the error “Unexpected Error” comes up. I have rebooted both machines but the connection cannot be re-established.
Any ideas folks?

Hi @Alan_McMillan,

Have there been any changes on the Windows 10 machine recently?

  • Have there been any Windows updates around the time this occurred?
  • Can you verify that the destination folder is still shared over the network on the Windows device?
  • Has the Windows username or password been changed?

Hi @Dylan.
There have been some Windows updates lately. Nothing else has changed

Hi @Alan_McMillan,

Can you please share the following:

  • The path that is entered into Roon
  • A screenshot of the folder properties via File Explorer (see examples below)
  • A screenshot of Advanced Sharing



Hi @dylan
Here are the screenshots you requested. The path in Roon was deleted when I thought that would reset things so I’ve included a screenshot of what happens when I try to re-establish it.



Hi @Alan_McMillan,

If you include the Windows username and password does that allow things to connect?

Hi @dylan

There is no username and password on my machine.


If you use the IP address to connect instead of the machine name is there any difference here?

If you have another machine on the network, are you able to access the smb://alanspc/software share over the network?

Can you confirm that SMBv1 is enabled on the Windows device?

Hi @dylan
I’ve sorted it after what you said about an account username and password and the fact that there isn’t one for this machine. I turned off password protected sharing in the Network and Sharing Centre and now the folder connects as it should. Thanks for all your help on this one.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.