Database corrupted + Backup failure during upgrade to Roon 1.8

Intel Core i7 PC, Windows 10
Software serial: 53128DD4-2E16-4052-BFED-DD0B9AFD021C


500gb Fibre - Vodafone router WiFi and Ethernet


HDMI connection from Windows PC to Denon AVR


I waited to update to Roon v1.8, and attempted this for the first time yesterday. In the process, I experienced a database corruption issue which prevented the update from being completed. I spent some time on the forums as per the message and followed instructions to change the name of my local Roon folder and then reinstall Roon. I followed this process 3 times, each unsuccessful for a number of reasons. Note, I made a manual backup yesterday directly before attempting to update to v1.8, but also have a scheduled backups conducted weekly.

  1. einstalled Roon using original download dated 26/12/19 (sorry I can’t remember the build number) and then successfully restored the most recent backup. However, Roon would not allow me to connect to Tidal, even after rebooting multiple times etc. My Tidal account was logged in on every device I own. The issue was with Roon, not my Tidal account. I waited a few hours but no change.

This was a problem to me because I have an extensive tagging system for music added to my Roon Library from Tidal. The loss of this information will mean I have wasted the last year manually transferring my old iTunes library into Tidal via Roon. The tags allowed me to select tracks based on recording decade, mood, tempo and familiarity. In the process of transferring music across I noticed that my music tastes have broadened and so the data in Roon was different to what was in iTunes. There is no other source of this data other than that was saved in Roon. I believed this was safe due to the backup facility.

  1. Given that the backup was successful, I wanted to try reinstalling Roon to a newer build version in the hope this would resolve the the issue logging into Tidal. I attempted this twice, first with Roon 1.7 build 611 and also Roon 1.8 latest build. On both occaisions, the build installed but the backup recovery failed at around 8%. ALL backups failed around 8%.

  2. The final step i attempted was to create a completely new installation of Roon using v1.8. I have reimported all tracks from my iTunes and Tidal libraries. I do have playlist info from these libraries but all of the tags created in Roon are lost. Any attempt to restore from backups fail.

To say that I am upset is an understatement, I am distraught.

Please, there anyway that we can retrieve the tag data?

I don’t mind if this can only be Dione in an earlier version of roon as I can transfer the tag data into playlists on a site like soundizz.


Sorry I can’t help. I’ve seen other posts about similar problems under restoring to V1.8.

I suspect that there was subtle corruption of your database that was nonetheless backed up and that that subtle corruption was uncovered when you tried to do a restore using V1.8.

None of which would happen if Roon would simply check for corruption before doing a backup and not backup corrupted libraries.

Tagging @support to weigh in.

1 Like

That’s for responding, I was hoping to get Roon to have a look at this themselves. Thanks for tagging them in.

I also suspect there was a subtle database corruption, but the fact I did retrieve the backup first of all yesterday indicates that there is data in there which should be recoverable.

Otherwsise the 22964 tracks I have manually transferred from iTunes into Roon tagging 11007 of them in the last 12 months will all have been four nothing!

You don’t say where you made backups too. I’ve had thumb drives corrupt my backup and bring the Roon database/server down. Once had to start all over again in 1.7 due to a corrupt/non-existing backups on thumb drives, though fortunately I’ve never done extensive work in Roon like you have.

Roon should really have a more robust backup solution and definitely make a sticky here on the forum and elsewhere of NO thumb drives (alas they seem like such an elegant and simple solution hanging off of a nNUC). I’ve had one go corrupt since 1.8 (I don’t think they like attempting a scheduled backup if music is still playing) and now relying on my Synology NAS and small SSD external off the NUC for backups. Of course, your corruption problem may be something entirely else and not related to the physical medium you are backing up to.

The backups are stored in two locations on different internal hardrives. I did have a remote backup of those drives running for years but it needs reconfiguring so its all located on the one device currently. Not that it matters if they don’t work!

I am now kicking myself for trusting the marketing information Roon gives out about how reliable their service is. I never take for granted that kind of thing normally.

Because I’ve run into corrupted backups a few times, my current backup scheme -

I am definitely going to be looking at a more robust procedure for backing up my data following this. What’s evident is that it’s not only where the backups are located but also how can I restore data if the Roon backups fail. I love Roon, but if this process results in a complete loss of data, there is no way I will trust Roon backups ever again.

Yes, once the word is out that Roon loses one’s careful curations then all the spiffy metadata in the world won’t help.

I dont want to get too far ahead of myself right now as I still hold out hoe that there could be a way to retrive some of the data. I’m just waiting for the hero’s in @support to come to the rescue…

Good luck. I wait with great anticipation.

No matter what happens here, it doesn’t change other instances of the problem.

Thanks, I need it!

Hi @Nathan_Fowler — You have our apologies for the trouble here!

Just to confirm:

  • Your backup from last week fails at 8% on Roon 1.8
  • If you install Roon 1.7, and you restore the same backup, it works with no issues

Is that correct?

Can you try restoring the backup one last time on Roon 1.8 and, right after it fails, use the directions found here and send us over a set of logs using a shared Dropbox link. We’ll take a look at the logs to see what was happening during the restore process.


Hi Dylan, thanks for getting in touch. To clarify, the first time that I reinstalled Roon (the version that I first started with in Dec 2019) the backup restore process worked. I didn’t stick with that version of Roon because of the issue with logging into Tidal. Without being logged into Tidal none of the tags showed up. After this all other attempts to restore from backup using a later version of Roon 1.7 and Roon 1.8 fail around 8%.

I will make another attempt to restore the backup now and follow your instructions if it fails.

Hi Dylan, I have zipped up my logs folder, and uploaded to dropbox. Can you give me the contact email address you want me to send the link to please?

Nathan, you can send the link in a PM. Roon frowns on putting emails in forum posts.

Just click on @dylan’s icon in his post in this thread and then on message.


Brilliant, thanks @xxx

A post was split to a new topic: Roon on iMac closes after 2 seconds

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.