Database not loading all of a sudden

Roon Core Machine

ROCK 1.0 (227 stable) installed on NUC

Networking Gear & Setup Details

Some 1Gb switches, PA-220 doing DHCP/FW, no problem there

Connected Audio Devices

Roon app on Mac, app on IOS, both not working currently

Library Size

I guess around 30k tracks yes, local on HDD and Qobuz

Description of Issue

I noticed audio started stuttering briefly while playing Qobuz via the Roon App on the mac. Skipped a song, same. Then after a while Roon app disconnected so I killed it. Started it again and I got the “There was an issue loading your database”. Same happens on my IOS. Connected screen to the NUC, IP is ok, no errors seen (you should be able to reach on IP … ). Wonder how to troubleshoot this :slight_smile:

PS: all UI checkboxes are green on the HTTP interface.

Operating System
Version 1.0 (build 227) stable
Running 16 minutes, 28 seconds.
Roon Server Software
RestartToggle Dropdown
Version 1.8 (build 814) stable
Running 16 minutes, 20 seconds.
Roon Database & Settings
98% of 114 GB available.
Internal Music Storage
2000GB, ST2000LM015-2E81 72% of 1848 GB available.

This indicates a corrupted database.

Do you have backups?

As I was afraid of. Is there any repair utility available? Which answers your previous question… “not really” :slight_smile:

Hi @Eric_Doezie

Can you send logs from your install? I’d be happy to take a closer look at what’s happening here. To send logs, please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service).


Hi there @dylan , thanks for your positive reply :slight_smile:

Please find attached the logs below. I really hope my German Schlager collection didn’t break the database…

Thanks, @Eric_Doezie. I’m checking with the team on what I’m seeing in the logs and I’ll get back to you as soon as I have their feedback. In the meantime, can you try something for me? I’m curious to know if clearing the cache here results in any changes.

  • Stop RoonServer via the Web UI
  • Find and open your Roon database
  • Navigate to RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Hi there @dylan, thank you for the quick responses! Clearing cache didn’t help, all worked without errors, cache repopulated (2 httpcache folders, sessions and smc.db) but still no Roon app connectivity, same error.

Thanks for giving that a try, @Eric_Doezie.

Unfortunately, after speaking with the team, it sounds like your database is corrupt.

We’ve traced a few reports like this in the past to failing hardware or power outage issues but generally speaking, this means that Roon is reading information from your hard drive that is different from what was originally written, and the database is now unable to load properly.

What’s Next?

If you’ve been making regular backups, my advice would be to install Roon fresh on your Core machine, and roll back to one of your backups. You can use these instructions to do so:

  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your ROCK’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database
  • (Optional) - Restore your database from a Backup prior to the issue starting

If the database loads properly, your edits, playlists, tags, etc should be intact, and we can confirm everything is performing properly once it’s been restored.

If you do not have any backups, unfortunately, you will need to start with a fresh database.

Please accept our apologies for the trouble!

1 Like

Hi @dylan, clear on the corruption part :wink:
08/16 13:48:37 Error: LevelDb.Exception: Corruption: corrupted compressed block contents

Is there any way to possibly recover the DB? I’m comfortable running scripts and any linx foo required. I would prefer to have it back alive than start fresh seen the lack of backups (my bad, I know). To then set up proper backups. It was the last thing I still needed to do but honestly didn’t expect a database to go inconsistent causing the whole ROCK to fail.

Unfortunately without a backup, there is no way to recover database data. You have our apologies for the inconvenience, @Eric_Doezie!

I definitely recommend making regular backups moving forward, and I’d also recommend checking the hardware on your NUC. We have more information about this here in our Help Center.

Make backups to multiple locations/devices too dont trust just one

Ach, it’s always the IT people that forget their backup :slight_smile: Thanks for the help @dylan , as product improvement it might be nice to have database snapshots to roll back to at some point in time (specially seen the small size of the DB). No power issues whatsoever on the NUC so all I could think of would be related to the SSD. And well, setting up a backup, good lesson.

1 Like

Really, a lot of these database problems could be avoided if Roon would simply take checkpoints before they undertook a critical update to the database, as is done in any responsible app.