Database restore fails

Core Machine (Operating system/System info/Roon build number)

I am trying a demo Nucleus.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Classic LAN

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Attached HDD

Description Of Issue

Before moving to the Nucleus, I did a backup on my laptop (which was my previous Roon Core), and a usb attached HDD.
I attached the HDD via USB to the Nucleus.
I choose database restore, and browsed to the directory of the backups, but I get the message : no backups found, please check your backup location.

Hi @Philippe,

Can you share a few screenshots of the backup folder (preferably from your Roon Remote)?
You can use these instructions to upload screenshots here.

– Noris

@noris: I replied to your email but here it is as well

Hi @Philippe,

Thanks for sharing that screenshot. It appears that you are missing the Roon Backup Root file in that screenshot. How did you perform the backup on the Laptop? Did you use Roon to create it or was it already created and you only copied it over? I would suggest connecting the drive to the laptop again and use Roon’s Backup manager to create the backup if you simply copy + pasted the folder over. Can you give that a try and let me know if it helps?

– Noris

Hi @noris ,

To create the backups, I used Roon. When Roon asked for the location, I browsed in Roon to the Seagate HDD. Roon created the folder with long string of numbers and letters. I did the same on my laptop, to have two backups in case one failed.
When I got the error message to restore, I used my laptop to create a RoonBackups folder on the Seagate, and I copied the above mentioned directory created by Roon in that folder. I tried a restore from that, but got the same error message.
I also tried to restore from the laptop backup, but got some other error messages (something like folder not authorized).
So in a nutshell, I already did what you suggested because I used Roon’s backup manager to create the Seagate and laptop backups.

This really annoying because I have been using Roon for several years, and would really like to keep my database in this transition to Nucleus. As a side note, I will probably return the demo Nucleus and buy a Nucleus + because my Roon library is around 11 000 albums and 170 000 tracks and growing.

I appreciate your help and really hope you can help me restore all that accumulated Roon history.

Hello @Philippe,

How is your HDD formatted, are you using NTFS, FAT32, or exFAT? I think you may have saved the Laptop (Roon created) backup on the drive’s root folder which may cause some issues with restoring. Let’s try this:

  • Connect the HDD to your laptop again
  • Create a new folder on your hard drive called “Roon Backups Laptop”
  • Use Roon’s backup manager to point to that folder and save a new backup
  • Disconnect the HDD and connect it to the Nucleus again
  • Point Roon’s backup manager to restore the newly created “Roon Backup Folder”
  • See if there is any change in that way

– Noris

I will follow your instructions.
The database is big, so this will take a while.
I will let you know.
Thank you for your kind help.

1 Like

Awesome, it worked!
Thank you so much, Noris!!
Great customer support!!

1 Like

Hi @Philippe,

Glad to hear that!
I hope you enjoy demoing that Nucleus!

– Noris

Thanks amongst other things to your great help and support, I have ordered a Nucleus + from my local dealer.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.