dCS Rossini DSD128 setup over USB [Solved]

I have Roon interfacing with a dCS Rossini via the USB1 connection. . In Device Setup, I have selected DSD over PCM (dop). However, in the DSP engine upsampling, DSD 64 is the only option. With the Rossini, it is capable of up to DSD 128. Any thoughts or suggestions?

Did you set exclusive mode in the device playback tab?

Yes it’s set to exclusive

If we’re only offering DSD64, it’s because either:

  • The device isn’t reporting capabilities beyond that (in your case, that means it’s not reporting that it’s capable of 352.8kHz PCM, since that’s the envelope used for DSD128 in DoP mode).
  • The Device Setup screen for that device in Roon has maximums set up that are interfering with this like “Max DSD Rate”

What does the top of your device setup screen look like?

Check this one–it should be “Disabled”

Under bit perfect format support, 352.8 384 and dsd 128 256 are red all others green, so Roon is not recognizing the higher resolutions. Dsd playback strategy is selected as dsd over pcm. dCS says the Rossini should handle dsd 128 over pcm with a USB class 2 setting selected ( which I’ve done).

Also max dsd sample rate gives options of dsd 64, 128 and 256.

I do think the issue has to do with the Rossini as I tried to play a 352.8 kHz file and it only shows up as 192. Thanks for your reply though!

Hi @Mark_Lindsay

Give this a shot:

Disconnect the USB cable from the rossini
On the front panel of the Rossini press the menu button
Press the > key twice to get to “Unit Settings”
Press the > three times to get to “USB Class”
Press the menu button to reset to Class 1 (wait for the operation to complete)
Press the menu button again to reset to Class 2 (wait for the operation to complete)
Press the power button to exit the menu

Now reconnect your USB cable and see if that clears it up.

I’ve seen this issue before on the Rossini and Vivaldi (just a couple of days ago, in fact). Occasionally the USB receiver gets confused and misreports. Resetting the USB class forces a reload of the code on the USB receiver.

Followed your advice but Playback on Rossini still reports as 192 on the file which is shown as 352.8 on Roon. Thanks for the help though.

That’s odd as resetting the interface usually clears up problems like this.

What device are you connecting to the Rossini via USB. If it’s a computer then what operating system version?

Lenovo T540p thinkpad running windows 7

It’s been a long time since I’ve used Windows 7 for this so I’m a bit fuzzy, but this is sounding somewhat familiar.

Do you have the latest version of the Rossini USB driver installed?


If not then you should disconnect the Rossini, remove the currently installed driver, reboot, and install the new version.

If that’s the driver you’re using then reboot the thinkpad and the Rossini (hold down the power button until the display says “SWITCHING OFF” then release, wait 10 seconds then power back on with the front panel switch).

I was able to resolve it. With Device Setup in Roon 1.3, there is a menu option to work around drivers that misreport device capabilities. I turned this on and now am able to play 352.8 pcm as well as dsd 128 files. Thanks to all for their help and suggestions, hope this also benefits others.