Dead Nucleus, not discovered but powers on Rev B

Hi. I have a dead nucleus (2TB, rev B). It’s only a couple months old. I was moving it to another room, and after the move it simply isn’t discovered. The power light comes on, and the network lights do light up but it is not discovered by the web mobile or windows apps and not identified by my router (netgear orbi). I also tried connecting and HDMI cable and keyboard and had no output. I’ve tried multiple network cables to eliminate that possibility, and verified cables were good on other equipment.
I have contacted Roon support directly through their web form but got no response for several days. What do I do? I purchased from Roon directly. Very frustrated with this $3000 purchase and zero place to turn for help. They don’t publish any emails or phone numbers, does anyone have them? It was a wonderful product while it lasted.


@support just tagged support for you explicitly. Nucleus issues should get better priority IMHO.


Thanks @wizardofoz for tagging support.


We appreciate your incredibly kind post, when you first emailed us late on Friday. We’d love to help out. Over email I suggested a network rest as a first troubleshooting step.

On whatever platform you prefer (here, on community or over email), we’d love to help sort this out.

I am having the exact same issue with my Nucleus Plus.

Tagging @support

I did end up contacting support directly and had to send the unit in for RMA. Hoping to have it repaired and returned in a few days. I suggest using their support online support form and doing the same. Unfortunately it did take a few days for a response, but I eventually got it handled.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.