Debugging the Storage Scanning Process

My setup:

  • Roon Server running on ‘Late 2014’ headless MacMini (3 Ghz Intel Core i7; 16 GB RAM; 500 GB Flash Storage) - this box ONLY runs Roon Core

  • All music files on a Synology 416Play with 16 TBytes disk running RAID-5. Synology box is dedicated to media storage and in addition to standard Synology NAS O/S it runs only backup software.

  • My library uses all Watched folders on the Synology box. I’ve divided my library into 5 primary folders (genre) with Artists->Albums->Tracks underneath.

  • My library consists of just 650 albums and roughly 8000 tracks.

  • Always running the latest Roon software

My question is how to determine what’s going on during a forced rescan?

My issue is that it takes several hours, sometimes two days for Roon to ingest a new album. I used to be able to get Roon to pickup a new album immediately by either doing a Forced Rescan of the folder or terminating Roon Server and restarting after a minute. But these days it seems that no matter how many times I force a rescan, restart roon, restart the macmini where Roon Server is running, it just doesn’t matter. Roon will ingest the album when it damn well pleases and not a moment before.

Are there logs that I can view to see what’s going on? Is there another trick I can use to guarantee Roon really does scan for new material?

Thanks in advance for your help…

Hi @rayski ----- Thank you for the feedback and sharing your observations with us. Both are appreciated.

Moving forward may I ask you to please provide a screenshot of your “storage” tab in Roon so we can see how you are accessing the NAS from the software and ask you to verify what SMB version you are using.


I am running the latest version of Synology DSM software, updates automatically as DSM software is made available, 6.1.1.-15101 Update 1.

Here are the SMB settings on the NAS:

Hi @rayski ---- Thank you for the follow up and providing the requested information. Both are appreciated!

Moving forward, can you confirm that none of the content has ended up in “skipped files” and furthermore can you please try engaging (if it is not already) “Enable SMB durable handles” in the advanced setting on the NAS to see if this triggers a changed in behavior here.


I “Enabled SMB durable handles” as you suggested, loaded a new album, forced a rescan and it immediately loaded. Possible coincidence? I hope not. I’ll try a few more albums tomorrow and let you know.

Regarding “skipped files” where can I find that information? I’m looking at the log files and it isn’t obvious to me. Am I looking in the right place? Is there a code name for skipped files?

It’s in Settings > Library > Skipped Files.

Glad that setting seems to have helped rayski – let us know how it goes, ok?

Nothing there now but that might be because all the files are loaded. I’ll play more tomorrow and let you know. Thanks!

I added a new album late last night, woke up this morning and it’s not there. I tried a Forced Rescan of the folder and still not there. Restarted Roon Server and still not there. I checked the Skipped Files and just a few jpegs there that have nothing to do with the recently added album.

I’m confident Roon will eventually decide to add this latest album, it always does, but it seems to be taking a very leisurely time doing it these days (24-48 hours, no matter how many times I rescan).

I should also not that I restarted my NAS this morning and still Roon is slow to find this stuff.

Hi @rayski ----- Thank you for following up and sharing the observations you have made since giving the proposed test a shot.

I would like to grab some logs from you and will be contacting you shortly via PM with instructions.