Default volume to 100 - Naim Uniti 2

Same here with my Uniti 2 via the UPNP Bridge. I also have the ‘comfort’ setting well down from the 100 maximum but it’s seemingly being ignored / overridden somehow. Really need this to be resolved before my speakers are well and truly trashed!

Hi Eric. Please understand that this issue is not just confined to the KEF LS50W.
My Naim Uniti 2 is also falling victim to the ‘default to 100’ volume trait that Roon seems to have. I first started noticing it after I (unsuccessfully) tried the Sonore UPnP Bridge in my Sonictransporter i7 (hoping to use the Uniti 2 as a Roon endpoint). My default is currently to feed a Holo Audio Spring DAC’s fixed output into an analogue input on the Unit 2, and use the Unit 2 for volume control duties. The Uniti 2 continues to be network connected (wired ethernet to a switch also used by the Sonictransporter, the switch then being connected to the Router via powerline adaptors), but the Uniti 2 is used solely as a CD Player, amplifier and internet radio (not as a streamer). The problem seems to occur when first launching the Roon App on my iPhone or iPad and playing the first track. Once Roon is established, it seems to behave itself and allow the volume to be solely adjusted by the Uniti 2 remote or the slider in the Naim App. Really glad that you guys are at least looking into this for us. I would like to be a long-term user of Roon if at all possible.

Hi @Dave_Woollard ----- Thank you for touching base with me and reiterating this observations you have made with the Uniti 2. I touched based with the team today and have split your post(s) over to their own thread so we can address this behavior with the Naim device directly. We have clear steps on how to reproduce the KEF issue being reported and there may be a similar bug here, but there could also be something else going on. So we want to make sure we are addressing these reports accordingly :microscope:

Moving froward, can you please provide some further insight into what exactly the chain of communication currently looks between your core and the NAIM endpoint currently looks like in your setup. Furthermore, if this behavior is indeed reliable reproducible can you please lay out the the steps you are taking (from a procedural standpoint) to trigger the issue.

Looking forward to your feedback Dave, thanks again!

Hi Eric. I’ve not had much chance to tinker so far this weekend as it’s my twin daughters’ 3rd birthday. But, as ‘music’ was needed for their party, with everything else already powered, I powered up the Sonictransporter i7 from cold, waited for boot routines to complete then launched the Roon App. The app immediately caused my Uniti’s volume setting to jump from 15 to 100 (maximum). After this, I of course reduced the volume rapidly and the control behaved normally for the rest of the afternoon.

The ST is connected to an external USB3.0 enclosure housing a 1TB SSD (my music collection) and a Tp-link 5-port switch ‘in parallel’ with the Uniti 2. The switch is connected to my router via Solwise AC1200 powerline adaptors. The ST is also connected to a chain consisting of a mR, modified Singxer SU-1 (d.c. powered) and a Holo Spring L1 DAC, which is itself connected to an analogue input on the Uniti 2.

The ST has Minimserver which the Uniti 2 uses if I select it’s UPnP option, but I can also use the Uniti 2 as a Roon endpoint via the Sonore UPnP Bridge within the ST. I think either the use of Minimserver or the UPnP Bridge triggered this issue which seems to be well established now - even when solely using the Uniti 2’s analogue input and not the UPnP features (as was the case today).

As I said above, I’m not at liberty to try repeated attempts to force the problem today, but I will do the same routine tomorrow if I get a chance.

Hey @Dave_Woollard – we’re looking into this, but just to make sure I’m understanding – based on this:

So, the UPnP Bridge is shut off, and Roon has no connection to the Naim device, is that right? It’s just receiving analog out from the Holo Spring?

And you haven’t done anything to setup volume control for the Naim in Roon, but somehow starting up (or doing something else) in Roon seems to be resetting the volume on the Naim?

Does anything else control volume on the Naim? Any other remotes, UPnP devices/apps, home automation, etc? It’s only connected to the Ethernet for internet radio I guess?

Hi Mike,
Currently, the UPNP Bridge is activated in the ST, but I’m not convinced it matters now (the problem also occurs when the microRendu is selected as the Network output).
The volume can be controlled via the Naim App (for all Uniti playback options including “Analogue 2”), and I have been using that.
In Roon, all I have done is tried to set Comfort/Maximum volume limits, but these seem to be overridden.
Thanks for your continued efforts.

We made a revision to the SonoreUPnP Bridge code to pass information about volume. Update your micro/ultraRendu via Apps / Software Manager. Proceed with caution we don’t have your device for testing so no clue if it will work properly.

Hi Jesus,
I’ll have a play later, thanks, but note that the issue occurs mainly when the bridge is using the Uniti 2 as the Roon endpoint. Although, this may well at least help when using the Uniti 2 merely as an amp for the microRendu playback chain.
Thanks for your investigations so far.

2 posts were split to a new topic: Nami UnitiQute 2 jumping to max volume