Delay all background processes while music is playing

Currently, Roon will do its background processing whenever it feels like it, whether it be in the middle of music playback or not. I can hear when Roon starts this process in the quality of playback. Roon already has issues with sound quality, this isn’t helping. Maybe this should be looked at and made a setting where the user can decide if they don’t care, or if they would rather Roon do its processing overnight or while music is not playing.

1 Like

Computers by their very nature are continually running many processes in the background. What particular background processes are you referring to? What impact do they have on SQ and how do you connect this impact with the background processes rather than something else?

1 Like

It’s in the developers’ nature, not in the computers…

1 Like

I’d say more accurately it’s a feature of the operating systems typically used on desktop computers.

1 Like

well, you may be right if it wasn’t Roon using more than 1 core and running it at full speed while every other process either idles or uses less than 1% processor, which is less than 1% of one core. Secondly, I don’t know what Roon is doing when it decides to do that, but I do know it’s doing it. I can hear it, and then I can SSH into the machine and see it as well.

you’re assuming I am running a desktop OS…

Isn’t that a fair assumption? Does Roon Core run on anything other than desktop OSs (genuine question)?

Linux Server?

Hmm, I think of Linux as fundamentally a desktop OS - that’s certainly its background, and at least it falls into the same category with respect to use of background processes.

(By contrast I had in mind embedded operating systems or bare metal.)

Anyway, this may be a little off topic for the main thrust of your post.

Yes, you are correct they do. However they normally do not use a full core+ when not needed. This is exactly what Roon will do at any random time and it lowers the sound quality.

the proof is in the fact that when I shut down roonserver completely with

sudo systemctl stop roonserver

and use HQPlayer by itself there is a huge jump in sound quality, everything else is identical.

If you deploy Roon according to the manufacturer’s recommendations for sound quality, you will not have this issue.

When all else fails…read the instructions. :wink:

Sure, I should take their word for it and ignore what is easily observable and repeatable, and that which many others agree on as well.


please tell me how I am deploying it incorrectly?

It should only take you a few minutes to read the sound quality recommendations that I shared.


If there is a USB cable between Nucleus and DAC, you’re not following Roon’s recommendations for sound quality.

Many (most?) subscribers achieve acceptable results even when ignoring these guidelines, but if you’re not happy with sound quality from Roon, you likely could benefit by following them.

that’s a lot of assumptions that have no bearing on my sound quality because even if that were true, my point would STILL stand.

Your system is what exactly?

1 Like

about to be running Euphony OS because I am completely done with this nonsense.

Hmmm, I don’t follow. What assumptions? What point still stands? If you follow Roon’s recommendations, in good faith, I’ll be rather surprised if you remain unhappy with Roon’s sound quality relative to alternatives in the same system.

For example, instead of connecting a USB DAC directly to Nucleus, move your Nucleus out of the listening room. (I know, it’s pretty, but it really does not belong in your audio rack). Put it closer to your Internet router…perhaps in a closet somewhere. In it’s place, add a dedicated endpoint device, like the new ZEN Stream from iFi Audio, or the Stream Box S2 from Pro-Ject. Even a $35 Raspberry Pi4 running VitOS or RoPieee will likely be a substantial upgrade because they enable you to leverage Roon’s distributed architecture to improve sound quality.

If you have a USB DAC connected to your Dell XPS 15 laptop, Roon Labs recommends installing Roon Bridge. This will enable you to exit the Roon desktop app after initiating playback. Music will continue to stream to your DAC via R.A.A.T. and the (lightweight) Roon Bridge app running in the background. Of course, if you can move the DAC to another dedicated network bridge, you’ll almost certainly experience better sound quality from that zone, and you’ll be able to move your laptop about without being tethered to a DAC.

I do realize that your post is in the Feature Request section, however, I doubt Roon will make this change since the symptoms you are experiencing are already solved by leveraging their distributed architecture.

ok, here you go

a PC, for lack of a better term, with a 5950X Ryzen 9, a 3090 NVIDIA gpu for HQPlayer and CUDA use, 32GB of 3600MHZ RAM, a 1TB nvme drive and 2 10TB Seagate IronWolf HDDs. The OS is Ubuntu Server and it runs on ZFS. I have a JCAT NetCard XE in there that connects to the network. That goes out to a ubiquiti switch flex mini and then to my NAA, a Sonore Signature Rendu Optical, and then USB to my DAC.

So please, tell me where I am deploying it wrong? Tell me how it isn’t Roon when that exact same hardware when not running Roon does not exhibit the same problem?

1 Like