Delay when Roon plays tracks in Tidal

Core Machine (Operating system/System info/Roon build number)

iMac + Roon version 1.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Shaw Wifi - standard model

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Naim Uniti Atom
Description Of Issue

When i start a track in Roon, it plays for about 10 seconds then stops. There is a delay of up to 30 seconds and then it starts to play again. Generally from about 30 seconds further into the track.

What happens if you have your iMac connected via LAN cable? If the unity and iMac are both on wifi I would suggest trying both connected to the LAN wired router or switch.


What results do you get on or for your internet connection?

out of interest what model/year imac are you using

Hi @James_Harris,

The questions that @wizardofoz asked are definitely great to know:

  • Model/year of Mac
  • Speedtest results
  • Trying with an Ethernet connection

Additionally, I’m hoping you might be able to confirm the following:

  • Does this happen for all endpoints or just the Naim?
  • Did this always happen with TIDAL or is this a new issue and it worked previously?

could be some transitory internet connection speed issue too

@James_Harris just a thought, have you tried using or DNS?

iMac is the retina 4k, late 2015 with 8gb of memory

Download speeds 331 mbps
Upload speeds 15.8 mbps

I have not tried with an ethernet cable yet.
Naim is my only end point.
There’s always been some issues with Tidal and the Naim via Roon. Some moments when the sound dropped out, but this is worse than before.

Not tried using or DNS?

I wondered what was the best way for Roon to communicate with the Naim?

Hi @James_Harris,

I definitely recommend using Ethernet if possible, even if just for a test. It will help us understand where the issue might be coming from.

Cloudflare and Google DNS are also good options as we’ve seen them help in similar situations.

Can you try playing to System Output of the iMac Core instead of the Naim? Does that work for you or do you see the same issue?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.