Delay when starting a Live Radio

Everything is working after a while but the start up is delayed possibly 4 minutes. I am running Roon core on Ubuntu so was able to load and capture the network information using Wireshark. A simple read through of the packet stream shows my Roon connecting to and exchanging information all of which looks reasonable. At around 5 seconds in the remote sides sends an Encrypted Alert, usually a sign that the session will end. Normal TCP handshaking follows and ends the session. About 252 seconds in an ACK comes in, I assume the station data streams starts and so does the Live Radio playing. This has worked correctly for months with a few seconds delay, just started this behavior recently. Any thoughts where to start looking.

Hello @Michael_Brown , and welcome.

Does the problem occur for all stations or just the one? And if so what station is it?
Are streaming services OK?
Is it the same for a different endpoint?

(Apologies for a basic question, but it’s worth checking - have you rebooted everything?)

Thanks for helping out. I have tried a few stations. Just now I was listen to Rock95 Barrie. I used Roon from a WIN10 PC to the core, checked out other Live Radio stations and clicked on Indie88 Toronto. There was a pause of over a couple of minutes and now it is playing. I have rebooted the Core OS, running Ubuntu. The pattern is not exactly the same, different delay put basically similar from my iPhone or PC streaming to RoPieee 3.113 or an ELAC Discovery Z3. Have rebooted the RoPieee and ELAC.

The firewall is a commercial Watchguard. The live monitor, block list and logs are not showing any blocked packets or IPs. DNS has been tested and is working. Everything else I have tested ( lightly ) is working. I just streamed some SiriusXM which is OK.

If there is nothing going on with the Live Radio streams then it must be something here. Just odd that it started when I don’t think anything has changed. Something did.


I took a guess and have fixed the problem. I noticed that the setup with Roon Corp and Live Radio servers is encrypted ( HTTPS ) but the radio stream is not ( HTTP ). So I wondered of the firewall gateway antivirus might see it as an object and try to scan it. Nothing blocked or dropped, just held up getting scanned. The speed and bit rate might have an effect on the delay time.

I created a specific HTTP proxy rule for the Roon Core IP outgoing and disabled the GatewayAV.

Works correctly now. Not sure what changed or when. Something always changes.



Impressive detective work, well done.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.