Deleted albums still visible, but not on all remote devices

(Max Delissen) #1

Core Machine (Operating system/System info/Roon build number)

Mac mini (Late 2012) with 2.5MHz i5 processor, 16GB ram, dedicated for Roon core (no other apps running, non-necessary functions like IR and Bluetooth shut off) with latest MacOS and Roon build numbers

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Synology DS412+ NAS, AudioQuest Forest, Carbon and Vodka wired ethernet, with AVM/FRITZ!Box 7490 router and D-Link DGS108 switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

AudioQuest Coffee USB to NAD M51 d/a-converter and Bluesound Node2 via network as Roon endpoint

Description Of Issue

For about a week now a deleted album keeps showing up in the Roon Remote app on my (6th gen) iPad. I deleted it because I made a mistake with the file format (wanted to use AIFF but used Apple Lossless instead) but when I tried to delete it from within the Remote app I got a warning that the file was in use. So I shut off the app and used the Mac mini in my office (so not the one with Roon core on it) to delete it by hand from my NAS. When I use the File Station app on my NAS to look for the file in question it isn’t there.

The funny thing is that the album is still visible in my iOS Roon Remote app on my iPad (see picture), while the iOS Roon Remote app on my iPhone doesn’t show it anymore (see other picture).

!

!

I followed the instructions in this closed thread:

but to no avail.

I clicked in the three dots next to the song titles of the deleted album to enter the details like the file path but obviously there is no info there at all because the file is gone. So using Roon edit to ‘hide’ the album doesn’t work either.

I disabled and re-enabled the Roon core from the remote app, I deleted and re-installed the app on my iPad, I restarted the NAS, I performed a Library Cleanup, what else can be done? A complete Roon core re-install is not on my list of favorites I must admit…

(Daniel Beyer) #3

Did you reboot the Core machine entirely?

(Noris) #4

Hi @Max_Delissen,

I would start off with a full reboot of both the Core + Remote as suggested to see if that helps.

Afterwards, I would kindly request a screenshot of your Roon Settings -> Storage tab from both Remotes, as it will be useful to see if Roon is by any chance still scanning any hidden NAS folders.

Also, just to confirm, is the behavior the same if you temporarily disable and re-enable the share in Roon Settings -> Storage for the affected remote?

(Max Delissen) #5

Hi Daniel,

Yes, I have rebooted the Core machine several times, and the iPad on which the album is still visible.

This looks like a minor glitch to me, so I have tried whatever I could think of to fix it myself before I would bother y’all with it :wink:

(Max Delissen) #6

Hi Noris,

Yes, Like I said to Daniel, I have rebooted the Core and the Remote a few times already.

I will make the requested screenshots for you later (after some coffee, it has been a short night for me :wink: )

And I also disabled and re-enabled the Share. Perhaps I should not disable it, but delete it altogether and re-install it. Shouldn’t that initiate a full rescan of the Share instead of an incremental rescan?

That may take a while (over 100.000 files to index) but it seems like a good option.

(Noris) #7

Hi @Max_Delissen,

Thanks for confirming you rebooted the Core. If you can please share the following it may be helpful:

  • Screenshot of Roon Settings -> Storage on both Remotes
  • Screenshot of Roon Settings -> General on both Remotes
  • Are you able to play both of these tracks, including the one you deleted?
(Max Delissen) #8

Ahaa! That question about the General Settings did help. In a way.

On my iPad, I had ‘Show Hidden Tracks and Albums’ switched ‘on’. Now that I switched if off, the album in question is gone from the Album view in Roon Remote. On my iPhone, this function was ‘off’. When I switch it ‘on’ the album reappears in the Album view

Still, it puzzles me why it is there at all, like a ghostly shadow, even after I removed the share completely and did a full rescan of my NAS. The ‘ghost album’ is definitely not on my NAS anymore, deleted it myself and saw it disappear from the folders list right in front of my eyes.

The tracks of the deleted album do not play. Roon will skip through them and display a ‘Too many failures, stopping playback’ message.

However, something did change after the most recent full rescan. When I tried to delete the album again, it now says there are 0 tracks. Before the rescan, the tracks were still visible in the ’Delete’ window (screenshot #2 below). The funny thing is that those non-existent tracks do show up in the album window.:

Here are screenshots of the Storage Settings on my iPad and iPhone:

(Daniel Beyer) #9

remove%20location

It looks like you have the actual RoonServer folder as a storage map. I would remove this. You don’t want to have the server database in a watched folder location.

1 Like
(Max Delissen) #10

You may be right, even though that folder is completely empty. I have now disabled it, let’s see what happens…

(Noris) #11

Hi @Max_Delissen,

I would give @Rugby’s suggestion a try and see if it helps. There can be some strange behavior when you ask Roon to scan it’s own database and it will be good to verify if this is impacting the issue.

If this doesn’t help, you may want to make a Backup of your current Roon database, remove (not disable) the watched folders, and then add them again as “new” directories.

Please do let us know how the testing goes!

(Max Delissen) #12

Well, disabling didn’t help, the ghost album is still there when I enable the ‘Show hidden tracks and albums’ switch, even after several new indexes of the watched folder that is actually supposed to be watched.

I have now deleted the Roonserver share from the list of folders (I have no idea how it got there), and we’ll see what happens.

If that doesn’t work I will delete it and add that same watched folder as a new one. Even when trawling through +100k tracks and building a new database takes a lot of time. On the plus side, that would give me a chance to catch up on the 20 or so new vinyl albums I bought over the last few weeks :stuck_out_tongue_winking_eye:

I’ll keep you posted, thanks!

1 Like