Deleted track remains in playlist

A deleted track remains in my playlist, and I’m unable to select it for removing from there, suspect because it’s unavailable.

Sounds funny but is true. Cleaning up stale data didn’t help as well. Can anyone help?


Sounds like something out of Catch-22 !
I’ll try to replicate it tonight and if so then we’ll get a bug ticket opened.

What kind of track? Local media or TIDAL?

Local media.

Hmm, I just tried and I can’t reproduce this. What am I doing differently?

  • I created a playlist with a single local track from my watched folder
  • I deleted the track from my watched folder and watched it disappear from the album in Roon
  • I went to the playlist and saw the unavailable track
  • I selected the unavailable track (I tried right-clicking and touch, but I’m on Windows – maybe you’re on a different platform?)
  • I clicked Remove and the track was removed from the playlist

Hi Mike,

I’m on an iPad Air (haven’t tried it on my Windows 7 PC) and the unavailable track is “untouchable”. That’s the difference I see.


Thanks for the report @NOA, we can reproduce the described behavior on the tablet.

You’re welcome, you guys are great!