Deleting backups doesn't delete [Ticket open]

I would have added this to another thread but couldn’t find a suitable one still open.

I backup my data as and when. That is, whenever I add or edit an album. No problem backing up and no problem restoring either. However, when I try and tidy up by deleting a backup, Roon pretends it has, but it hasn’t.

Here’s a snapshot before I delete…

Now I’ve deleted the old one…

Oh no I haven’t! It’s still there…

Files are on a Synology NAS 214play, connected by wire to Rock.
Roon has read/write access obviously or it couldn’t create the backups.

I’ve tried deleting all but the last three or four but they still won’t go.

Over to @support


Hi @BrianW ----- Thank you for the report and sharing this observation you have made with us, very appreciated!

Moving forward, while it may sound a touch elementary, have you tried rebooting your Roon core after you had tried deleting the mentioned backups in app? I am just curious if something is possible getting “stuck” during the process.


@Eric I reboot every day. Is that what you mean?

Thanks @BrianW, that’s what I was indeed inquiring about, thank you!

Continuing forward, all of the backups in your screenshots are from older builds (build 269), can you please try forcing a backup while on the latest build and let me know if it can be deleted?


Made a new backup…

Deleted it…

Close and open again…

Still there.

Hi @BrianW ----- Thank you for follow up and continued feedback. Both are very appreciated!

To offer a quick update on this behavior. I had a chance to discuss this issue with a member of our DEV team today and he reminded me that the team is aware of this behavior and that it is on the team’s radar (i.e a ticket is open in our system).

While I cannot say for certain when this will be addressed/fixed, the team has made it clear that it will be addressed in the near future. As I receive more information from the team on their progress I will be sure to keep you up to date.


Oh I missed that. I did look through back threads.
My apologies.