Demo on Nucleus+ Playlists wiped out playlist content

I’ve been a subscriber since March 2017. Took a Nucleus+ home to try. Signed in and my playlists show but they contain nothing songs show “0” . Playlists are all there.

NUcleus shows ans works. Connected to the network via ethernet. CLients are the original MAc as well as iPhone.


Hi @John_Rudolph — Thanks for reaching out to us!

NUcleus shows ans works

Just to be clear, on the Nucleus you’re able to see and play the tracks in these playlists, it’s just the remote devices that are not seeing them?

May I kindly ask you to verify the following:

  • Is all of your music showing outside of the playlists section? All of your albums and tracks are appearing correctly?
  • Do you use local files, stream from TIDAL, or a mix of both?
  • Have you tried rebooting the Core machine, remote devices, and network hardware?


Hi Dylan,

Thanks so much for your prompt response.

I have used Roon for 14 months using my MacBook Air as the core and controller. I have built up a playlist of Tidal songs as well as around 8900 FLAC files.

Yesterday I picked up a Nucleus+ to demo. I plugged the Nucleus+ into my router and used my MacBook Air wirelessly (As it has always been) to select the N+ as the core. I then used my iPhone to control the N+. It worked flawlessly and I was able to see all my playlists although the FLAC files on the original MB Air were not accessible.

To answer your questions.

•My music does not show outside of the playlists section when using the N+ as the core.
•I use a mix of local and Tidal files in my playlists.
•I’ve rebooted the Mac and the N+ and the Remote device (iPhone)

This morning I opened the MB Air and tried to access the N+. The MB Air connects to the N+ with no trouble and all my original Roon playlist names show up but each of the playlists shows “0” songs available. The Roon playlists are empty on the N+. When I disconnect the N+ as core and select the the MB Air as core my original playlists are there along with all the songs that they contain.

John Rudolph

Duh. I can be rather thick at times. I am a dilettante geek. I apologize to the other real geeks that wasted their time reading my foolish thread. You are my heros. I will never be like you. No doubt I need to simply backup my old Database and use a USB key to migrate it to the new N+.

I will throw out my pocket protector, remove the tape from my glasses and mother will be happy to see me move out of the basement, get a job and a real girlfriend. I am pathetic. I will keep the ponytail.


1 Like

Hi @John_Rudolph

It happens to the best of us :grinning:

Yes, restoring a backup of your Roon database on the new Core should do it. If you have any issues after that just let me know and I’ll be happy to help!


Not sure keeping the ponytail is enough penance, you should maybe take a leaf out of the new world snooker champion’s book.

1 Like