Devialet Air seek broken since 931 [Solved: Update to Build 952]

Hi @phantomtides,

Thank you for that! It’s a team effort for sure, we appreciate your issue reports. There’s no way we could catch this kind of thing as quickly without your help. :pray:t2:



INFO - I don’t know if it’s related to the current issue or not:
Over time, the Devialet AIR protocol has always required LESS network traffic than the Roon RAAT protocol.
Since the latest Roon versions, this has changed radically: the Devialet AIR protocol requires substantially MORE network traffic than the Roon RAAT protocol.

1 Like

I’m not seeing that, air still looks about 10% more efficient on my system. Have you checked upsampling and mqa unfolding are set the same?

1 Like

I’m not using upsampling and MQA, and settings are the same for both audio devices/protocols.
My Roon Core is installed on Intel NUC running Linux OS.

@jamie Do you have an ETA for the resolution? It will help to wait :slight_smile: Many thanks for your support :pray:

Hi @fver, @DanielAvasilichioaei, @Arnaud, @Kevin_Hughes, @phantomtides:

Thank you again for bringing this to our attention! We’ve implemented a workaround for your accounts which will resolve this problem for you. In order for the change to take effect, please restart your Roon Core twice.

If using a RoonServer/computer, close and reopen Roon twice. If using the Nucleus or ROCK Web Interface, use the “Restart Roon Server Software” function twice. It’s critical to perform the restart twice in order for the change to be applied. The first restart reads the new setting from our servers; the second restart applies it to the Core.

Once that’s done, the Devialet devices should function as they did in the past.

If any other users are experiencing this problem with a Devialet device, please respond in this thread, and we’ll apply the same workaround. Our team is working on a permanent fix, but we want to be sure everyone’s setup stays functional in the meantime.


It works. Only given it a very quick test but all good so far. Thanks for sorting it quickly.


works over, here. magically - no updates needed?


Thank you so much :gift_heart:
It works also for me :+1:t2:


May it be written and may it be recorded.

I did NOT do the double-restart, and it appears to be working properly for me anyway. (I have no idea either.)

Thanks to Connor and the Roon team. I think.

You are all the hundredth monkey.

Thank you, it works for me too.

Off topic:
Notes: These are older observations and are not related to the bug fix provided. I don’t know if they are specific to my system or if they are general.

  1. AIR consumes slightly less (insignificant) network traffic than RAAT.
    Instead, AIR consumes significantly more processor resources. Here is a test with streaming from Qobuz, track 96/24 in lossless mode.



  1. If both protocols are active and the “Transfer Zone” is used several times in succession, then at some point something strange happens with the RAAT protocol (and only this one): the sound changes completely and no longer corresponds to the real music. The closest description I can find: it is something similar to applying the “3D Spatial” effect that is available in some amplifiers / audio software.

Roon does all the work on the server converting flac to pcm, which means more network bandwidth but less processing at the end point.

I understand that conversion to PCM is made in Roon Core with Devialet AIR protocol, but not with RAAT protocol, right?
This may explain the difference in CPU usage.
I thought both protocols send music to Devialet in PCM format. See section Core / Managing playback to audio outputs, here:

Its converted in raat.

Ok, so FLAC to PCM conversion is not explaining the difference in CPU usage between RAAT and Devialet AIR. There must be something else requiring more CPU usage…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Thank you for the quick help. I tried this Solution (See Below) . But it doesn’t work.
Please help !

@Volker_Hase, we need to manually change a setting on your account for this workaround to go into effect. I’ve made that change so please try restarting your core again.

1 Like

Roon Core Machine

Intel NUC I3 with
Roon version 1.8 (build 936) and
RoonOS version 1.0 (build 227)

Networking Gear & Setup Details

Roon Rock wired via Ethernet and a switch TPLink SG108
iPad connected via the WLAN

Connected Audio Devices

Devialet D200, via wired ethernet

Number of Tracks in Library

About 10,000

Description of Issue

When I (using an iPad) advance the play progress slider (I mean the small white circle in the bottom of the window) Roon stops playing. Apparently Roon is not dead, for example it still responds to clicking on the progress bar. But it does not start playing again. The only workaround I found is to switch Roon off and on. The issue occurs both playing from the library and from Qobuz.

With the PC application all works fine.

What is going wrong?