Devialet source select not working with renamed inputs [explained]

New to roon so I may well have missed something obvious, but…

“Roon will also allow you to adjust volume, and power down your Expert system. And when you start playback in Roon, your Expert system turns on and selects the appropriate input automatically.”

Except on mine it doesnt, it can turn the amps off and on OK, but never changes the input to air.

I have my devialet config set to change the input to optical 1 on start up, and I have renamed all my inputs to match what they are.

Am I doing something wrong? Does this work for others?

Just tested mine.

Set the amp to spdif (which is a renamed digi1). Pressed play in Roon (Devialet setup with Roons native AIR) and it immediately set Ethernet and started playing.

However, Ethernet is left at default naming on my d250 and it’s too much of a hassle to change it to test for you (sorry).

Perhaps someone else has a renamed Ethernet, or you could try setting yours back to default and see what happens?

You’ve definitely setup using the internal AIR and not the AIR virtual driver? (I guess so if you can power cycle)

1 Like

Thanks, as it works for you I’ll try re-naming it back, just wanted to know it worked before I started fiddling.

Yes, internal AIR, I uninstalled normal AIR to simplify things for now.

Success, renaming the input back to the default fixed it.

It’s really nice to have this, will make my training the other half in how to use it so much simpler.

So either a bug or feature depending on how you look at it.

Probably worth us flagging @danny and @brian - it may be they can call the input by its internal name or ID (assuming such things exist) rather than the user-definable name.


In truth I can see how having the option to control the input manually might be prefered by some users, so leaving as is might be best.

We are keying off of the input names–I am not sure that there is another key we can use. I think we asked Devialet about this once, but I don’t remember what they said. We’ll look again.

@brian, Could you allow the user to set the input name in Roon to make it the same as the device?

Good idea…