Device connected to Linux Core not enabled

I just upgraded the box my core runs on to from Fedora 25 to Fedora 27 (whilst replacing a failed hard drive).

In Settings, I can see the Core machine’s built-in audio, but when I click to enable it, the settings modal for the device pops up for a brief moment, then disappears, leaving a “device not found” notice.

There is a USB DAC attached to the machine and that enables and plays just fine.

I migrated from the old machine by restoring a Roon backup as per the KB article here. Except for this, everything appears to be functioning fine.

Roon is at version 1.4, build 306 on both the Core and the Mac client I’ve been using.

Both firewalld and selinux are disabled on the Core machine at the moment.

libasound2 is present in an up to date version.

Audio from desktop apps on the Linux machine plays fine through built-in audio.

Music files are stored on an SMB share on a machine separate from the Core.

Roon played through built-in audio before the system rebuild.

Any ideas?


It turns out it was (sort-of) one of those order of actions things.

When I went back to the issue, I unplugged the USB DAC, which promptly disappeared from Roon’s found devices. But now I could enable the built-in audio.

Then, upon plugging the USB DAC back in, it did was not discovered. When I clicked “refresh”, it popped up and enabled itself.

The same behavior seems to be happening in reverse, as well. Whichever device is not in use disappears and will reappear and reenable upon clicking “refresh”. Then, both devices appear in Roon, as best I can tell until I switch from one to the other in Roon’s UI.

Weirdly, in my ALSA mixer on the Linux machine, both outputs appear to be active and choose-able as long as the USB DAC is plugged in. Which would seem to argue against my suspicion that ALSA was somehow granting exclusive access to one device or the other.

Previously, IIRC, both devices appeared in Roon, regardless of whether the USB DAC was attached.

So, if anybody can explain what’s going on with ALSA in Fedora 27, that would be appreciated.

And I wonder if there’s a preference in Roon that would auto-scan for devices whenever a zone is selected, or whenever a device change is detected?

Hello @Carl_Seibert,

Could you provide a snippet from your RAATServer log that corresponds with you seeing this behavior in the app? Instructions on where to find your Roon logs can be found here



I think I’ll be able to attach them here. They’re only 31KB.

At about 7:02 PM, I switched from one output t the other and back - this while the USB DAC was plugged in. I unplugged the DAC and plugged it back in. At 7:04 PM, you should see a manual refresh in the Roon UI. Then the USB DAC will be re-discovered and will re-enable itself.

Check that. I don’t see an attach button. Dropbox link:

Hello @Carl_Seibert,

I’m sorry for the delay, just wanted to chime in with an update. The tech team is taking a look at your logs and trying to reproduce the issue. They’ve asked for a few bits of information to help them diagnose what’s going on

  1. Do you know what is the model and manufacturer of the motherboard in the computer?
  2. How did you go about the process of getting from Fedora 25 -> Fedora 27? I see that you had an HDD failure, but was this a restore from a backup you had on a new drive and then upgrade in place? Did you do a clean install of Fedora 27 on the new drive then migrate your data?


Hi john,

The mobo is an MSI. I don’t know the model number off the top of my
head. It has on-board audio. Nothing fancy. According to the Roon
settings dialog, the sound card identifies as “HDA Intel PCH ALC887-VD

I installed F27 on a new, blank hard drive. Installed dependencies, then
installed Roon via the Easy Installer script and chose “Restore from
Backup” at the first run of the Mac Client. The backups were stored on a
different drive on the server. (Which was disconnected during the OS
install and re-enabled afterwards.)


Hello @Carl_Seibert,

Thanks for the info, I’ll be sure to pass it along to the tech team. In the interim, I did some of my own research and was able to find a few reports of issues with the Intel audio driver and Fedora 27. There’s a solution listed at the bottom of this thread that may help you out