"Device failed to initialize" appears randomly

The issue “Device failed to initialize” appears randomly in my Tidal playlists and makes the music stop. What can I do?

Core installed in Windows 10 with Topping d10s.

Maybe I found why. I previously set the dac “only renderer” for MQA and the issue compared for mqa tracks. Now it is “only decoder” and it seems to work.

No. It doesn’t work. I don’t know. I tried with Qobuz and the issue reoccurs. I think it happens mainly with tracks with high frequencies. I don’t understand. Sometimes the song does not start. Other times yes.

This issue is only in WASAPI mode. In ASIO mode no.

Hi @Vale_Ricci,

It sounds like the device is having issues changing sample rates when using WASAPI.

Given that the WASAPI API is standardized for all UAC2 USB DACs I don’t see how Roon could be causing the issue.

If the ASIO driver works I’d simply recommend using that.



Thanks john for your support,
could it be a problem of insufficient power supply of the USB port? I plugged in the dac on the same side as the external hard drive and maybe it gets less voltage. Today I try to attach it to another USB further of my laptop to see if anything changes.
I prefer wasapi, I have volume control, as I said in another thread, Asio is a bit cumbersome from this point of view.

Crossing fingers, it seems that changing usb works. So far no issue.

Nothing to do @john . I tried uninstalling the drivers and reinstalling them. The problem recurs in a seemingly random way. I don’t know what to do.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.