Device seen by Roon, appears to be playing, no sound output [Solved]

One of my Pis has stopped sending sound to the amplifier.
Setup is Roon ROCK on a nuc, all hard wired via ubiquiti switch to several pi endpoints all running Ropiee.
The pi in question is a 3B and I have just upgraded it to RoPieee 2022.11 (0580). Rebooted several times. Checked connections to the amplifier, tried another amplifier, tried different inputs. Nothing. All of my other pis running Ropiee are fine.
Roon core sees the pi and happily plays music to it - but no sound!
Any suggestions please? I’ve tried all of the things I would usually think of. Thanks so much
best wishes
Andrew

I suggest that you send feedback to @spockfish and post the feedback reference here.

1 Like

Thanks Geoff, will do

Have you checked the Ropiee web config page to verify it is still set up for your HAT/DAC as before?

Tony, thanks - I did indeed do that, Checked all the settings in Ropiee and all looks fine. Very confusing!
Thanks for the suggestion

So @ACB ,

Looking at your logs everything seems fine.

However, what you did not mention is that you have a DAC HAT with volume control.
And the volume is consistently low (13 in a range from 0…100).

Have you tried changing the volume?

Thanks

That’s odd - the endpoint has always run with fixed volume (or I thought it did!). I’ve changed it in Roon settings to variable and adjusted it up - no result. I have also tried connecting a USB DAC direct to the pi’s board in case it was a HAT fault, but sadly also nothing. I even tried to reset the HAT settings by configuring it in Ropieee as “no HAT”, running reboot and then reinstalling. Also no luck with that.
Thanks very much, Andrew

I’m not entirely sure about your attempts…

The HAT is an amplifier with volume control (and has no relation whatsoever with USB).
I see that the volume is set to a low level, hence I pressume that’s the reason why you are not hearing anything. And according to Roon it’s not set with fixed volume…

So I suggest you have a look at your settings in Roon because I’m pretty sure that client side (the Pi) everything is ok.

Thanks

Thank you Harry for your efforts and quick replies!
I’ve triple checked within Roon’s settings, which are as usual (and same as all of my other working zones). So since you say the client pi is fine then I’ll go off to search for whatever else might be causing it!
best wishes
Andrew

But that should have worked. It will need enabling in Ropiee (Audio USB set) and Roon and audio sending to it at Fixed Volume.

I think I’ve seen a case where device volume is remembered.

So perhaps switch the zone to device volume, turn it to maximum, then switch back to fixed volume.

@GregD Thanks very much - that seems to have done the trick. Not sure why it got itself into that state in the first place but thank you for the suggestion!

1 Like