Devices and Music Files Missing After Upgrade to 1.5


I have a Synology DE 1515+ and, after upgrading to 1.5, all devices and music folder are missing. Tidal is visible and navigable.
Synology OS is Linux 3.10
NAS is connected into Google Mesh.
All devices are Squeezebox - Squeezebox is enabled.
Approx 5000 tracks

Hello @Philip_Martin — Thank you for sharing your report with us, it’s appreciated!

To start, may I kindly ask that you please provide a brief description of your current setup using this link as a guide. Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Since experiencing this behavior have you tried rebooting your Core machine, the Synology, remote device, and any applicable networking hardware?


Thanks Dylan,

I’ve rebooted the NAS, WiFi Routers (Google Mesh) and devices:
I still see Tidal, I still don’t see any Audio Devices or my stored music (on the NAS)
The Synology NAS is the Core machine and connected to the network by LAN (on one of 6 Google Mesh Routers)
My Audio Devices are 3 SB Touches and a SB Duet. I use an iMac (late 2013 i5), an iPhone and 2 iPads as remotes.
Everything has been very stable until I upgrade to 1.5 last week.
If you need anything more specific please let me know.

Thanks for the additional info @Philip_Martin!

Can you please verify the following for me:

  • If you add new files to your Music folder, does it appear in Roon?
  • If you add a new folder to Roon and add files there, do those appear in Roon?
  • Besides the update, has there been any other change to your setup? Any change in networking setup?
  • If you install Roon on your iMac, are you able to see your files and devices?

Thank you,

Hey @Philip_Martin

I just wanted to check in and see how things were going. Were you able to get everything up and running? If you have questions just let me know!


I’ve tried the following:

Synology NAS - Core
Added new files and new folder to existing Music Folder - Roon doesn’t see them
Added new Music Folder and music files - Roon doesn’t see them
Devices still not seen

Nothing changed in system - only Roon 1,5 upgrade

Mac Roon Core
iMac Roon Core with Music Folders stored on Synology NAS
Music seen
Squeezebox Support Enabled - no devices seen, even after devices rebooted


Hey @Philip_Martin — Sorry to hear you’re still having troubles.

I’d like to recommend something else to try next. Recently we have traced similar connection issues to illegal characters being used in the password for the network share.

My suggestion is to modify the password used for the network share and try adding the folders to Roon again with the updated password. When you do this, make sure you are not using any special characters. Let me know if you are still experiencing this behavior after doing so.


I’ve modified the password:
Can’t connect to the music folder with network share when using the Synology NAS as the core.
I can reconnect to the music folder on the NAS when using an iMac as the core…but still no devices on the iMac.

Hey @Philip_Martin, thanks for the update.

Just to clarify here, are you wanting to use your NAS or the Mac as the Core moving forward?

I noticed that the Synology you’re using falls short of our recommended specs.

Because this device uses an Intel Atom processor you may experience performance issues, particularly with larger libraries or DSP, or if you don’t use an SSD for your Roon database.

It’s hard to say whether the issues you’re experiencing are related to performance, but we do like to give people a “heads up” when their system is under spec, since it can impact the product in a number of ways, and you may encounter some limitations going forward.


Hi Dylan,

Thanks, I understand the Synology NAS is below ideal spec. However, I’ve loaded up the RAM and have a SSD with the database loaded - I’ve been using it as the core for a couple of years without issue. So I don’t think it’s the problem, things only went South when I upgraded 1.5.


No worries, @Philip_Martin. You had mentioned using both as your Core above, so I just wanted to be clear on which you wanted to use moving forward.

Added new Music Folder and music files - Roon doesn’t see them

Just to clarify, you added a new folder in Settings > Storage and the files weren’t added to Roon?

May I ask that you please share a screenshot of Settings > Storage so I can take a look?

May I also ask that you confirm what version of Roon your remote devices are on? Make sure they’re fully up to date to ensure compatibility.


Thanks Dylan,

I’m using Version 1.5 (build 323) on my remote device.

Here’s a screenshot when using the NAS as the core:

Here’s a screenshot using an iMac as the core and music files on the NAS:

Appreciate the help and support with this,

Hey @Philip_Martin — Thank you for the screenshots, that definitely made things more clear!

Above, you mentioned you cannot see any of your audio devices. Are you referring just to your Squeezebox devices? Are you able to see any other RAAT devices (such as the Mac running Roon Remote or Roon Bridge?

Additionally I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


Hey @Philip_Martin,

I just wanted to confirm that the diagnostics report has been received and I have passed it along to the technical team for further analysis. I’ll be sure to update you on their findings when I hear back from them.

While they’re analyzing, may I ask that you verify that your Core machine does not have any firewall or antivirus active, and if so, try disabling it?

Also, can you please confirm this:

Above, you mentioned you cannot see any of your audio devices. Are you referring just to your Squeezebox devices? Are you able to see any other RAAT devices (such as the Mac running Roon Remote or Roon Bridge?

Edit: I reviewed your setup, and just want to confirm you are using a wired connection for the NAS? If not, I’d like to suggest moving your NAS and connecting directly to the router with an Ethernet connection and see if the experience changes.


Thanks Dylan,

I don’t have a firewall or antivirus running on the NAS, but do have Sophos on the iMac, enabling and disabling it doesn’t change anything. If I use the iMac as the Core I can play Tidal and NAS stored music through the Mac, but can’t see any other audio devices (all Squeezebox). Reverting to the NAS as the core I still see no music files and no playback devices.

Whatever settings I change I can’t see any playback devices.

The NAS is connected by ethernet to my router - however, I am running a Google WiFi Mesh system with 6 WiFi Points. So it’s part wired/part WiFi.

If it helps I have no problem switching the Core from the NAS to the iMac, it has a more powerful processor anyway so it might be the best option for the future :slight_smile:


Thanks for the update, @Philip_Martin!

For our next steps here, I’d like to focus in on the audio zones that are not appearing in Roon. A great place to start is our KB article on the subject.

Besides the Squeezebox devices, do you have any other endpoints that appear in Roon?

Can you describe how the squeezebox devices are connected to the network? Are they all on different Google WiFi access points? Can you connect one directly to your router (wired connection if possible) and see if you’re able to see it over the network?

Are you able to play to these devices fine outside of Roon?


Here’s an update Dylan, using my iMac as the core:
I’ve rebooted all the SB devices (this has worked before) and Roon still can’t see them.
Also rebooted all Google WiFi mesh devices and iMac.
I have one SB Touch that is ethernet connected and it’s not seen by Roon.
When I search devices using the feature in the Google WiFi app it sees all the SB devices - WiFi and ethernet connected to the same network.
All the SB devices can see the new library (iMac) but when they try to connect to it they’re unable to.

I still have LMS on the NAS, when I switch to this as the Core I’ve switched off Roon and tried to reactivate LMS but unable to…

When I use iMac as the Core I am able to play music files on the device that’s being used as the remote, so it plays through an iPad.

Any ideas?


I’ve just had another attempt at restarting devices and have a WiFi connected SB Touch up and running using iMac as Core…so, progress made!

Thanks for the update, @Philip_Martin!

Just to confirm, is it only the one WiFi SB device that is connecting? The device connected via Ethernet is still not appearing?

Are there any firewall settings on your router that may be active? If so, can you try disabling them?

Are you using any app that utilizes the network such as VoIP or VPN?

Are the SB devices on the latest firmware?


I was able to get all SB devices working, ethernet and WiFi - using iMac as the Core.
I didn’t change any network settings, the only change I made was ‘forcing’ the connection from a SB Touch rather than trying to connect from the iMac - but I’m not sure if this was the fix or not?

All the SB devices have the latest firmware, I’m still unable to use the NAS as the Core - but I’m fine using an iMac.

Appreciate all your help with this Dylan, thanks.