Devices won't enable

I am going through the pain of a fresh install on an NUC device !
Previously as a trial I ran Roon Core on an old Linux laptop; I am a IT engineer and so the install was a breeze, the product worked beautifully, sounded great, so I bought.

I decided to use a NUC for my real install as it seemed the simplest way to go, so bought an Intel NUC7i7BNH, plugged in a 128G SSD and some RAM and set about the install.
Unfortunately I did this at the time of the ldlinux.c32 problem, so waited patiently and frustratedly for that to get fixed, and last night downloaded the new software.

It installed without too much trouble.
However, running the Roon UI on my Windows 10 Asus laptop to configure everything I ran into a problem. I connected to my Core Server and added some storage, all good so far.
Then the audio devices are listed, all looking good; 4 Intel devices associated with the NUC plus my USB DAC (tried 2, a Schiit and Audioquest Firefly), tried to enable and it just sits there “enabling …” ad infinitum.

I believe I followed all the instructions, including adding ffmpeg so am baffled !!

From UI
Operating system Version 1.0 (build 157)
Roon server Version 1.4 (build 298)

I notice v1.5 announced, but the software I have is from the download page today, so how do I get the later versions ?!

Please advise

@Rob_Giggs If you go into settings on the about page it should show any updates that need to be installed - for Rock you can also perhaps do a reinstall from the main web gui

Thank you very much, the software update has fixed it.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.