Did Build 880 break all extensions?

I only use the Elgato Stream Deck extension, which no longer functions after Build 880. I ask the question in the title of the thread because the Roon core no longer sees an authorization request, so the Stream Deck extension isn’t just not working, it cannot register. I assume all extensions register in a similar fashion.

It depends on how the code connects to the API.

Extensions that used discovery to get the port number will still work, those that didn’t will likely need changes.


Ropieee and Deep Harmony still work for me. I did however had to to restart them all and clear previous authorisations.

1 Like

I’m not sure what you mean, not being a developer. Are you saying that if one manually adjusts the port number to register the extension it should work? What port number?

Or are you saying the extension developer has to adjust the code?

It depends on the extension. So there are 3 possibilities:-

  1. Uses discovery - these will just work
  2. Allows port to be specified (but probably assumed it was 9100 which it usually (nut not always) was in the previous version) - if it can be specified in the extension you can change it, You can see what port your core is using by looking at the number after the colon in the room app settings/displays - it’ll probably be something like 9330.
  3. Doesn’t allow the port to be changed - this will require a new version from the developer.

Thank you so much. That worked immediately.

1 Like

I have a similar problem. However in my case the Stream Deck Roon extension has completely disappeared. It no loner shows-up in the Roon Extensions setting.

If I remove and reinstall the extension from Elgato’s site, nothing happens. I’m running the latest versions of Roon, Stream Deck and the Stream Deck Roon extension.


If the a new authorization doesn’t show up for approval in roon settings, then It indicates the extension isn’t communicating with Roon core.

If there isn’t a way to specify a port number in the extension it probably needs an update from the developer.

Yes, I can change the port number. It defaults to 9100. How can I get it to communicate with the Roon Core? Entering port 9100 doesn’t help.

I think it started with the update to build 880. The new build, 882, hasn’t helped.

Take a look in the Roon App - settings - display.

It’s the number after the colon in the URL- perhaps 9330.

Port 9300 is working for me on Streamdeck.

Thanks, I checked the port number in Displays and it was 9300.

I used that on the Stream Deck Configuration and then the Stream Deck showed up in Extensions.

However it two instances of it showed up, both with the same version number. I enabled both and it is working.

Does anyone know where either Stream Deck or Roon store the extensions? It would be nice to clean it up and delete the second instance.

It’s in Roon.

Settings / Extensions

The live ones should be displayed.

View to see the not currently active.

I was thinking more about where the extensions are stored on the local drive so that I could physically delete the second instance.

Something is definitely funky though, as you can see the extension is listed twice in Roon. Let me see if I can include an image.

Over time you should be able to see which of the two is really live, and then remove the other.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.