DietPi image for Sparky SBC

(Mikael Ollars) #1

Am i the only one having a lot of issues with the DietPi image for the Sparky?
I got my brand new Allo USBridge a couple of days ago, and i am not too impressed with the slow cumbersome GUI which only works partly in each of the web browsers i have tried.
(Edge/Safari/Chrome/IE)

Anyway, i decided to try and image a microSD with a clean DietPi install. So i just now went to the Dietpi.com site and downloaded an image. It says on the file date it was created 20/01/2018 14:14:26 but when i start the USBridge with this card it claims to be of version 6.11? This image is about 90Mb compressed. It also claims to have all the software installed, like the Allo GUI version…
However, nothing is working, no web gui, no Roon Bridge etc…
And i am still bothered by the NTPD-error, but now it does 60 tries instead of 30…

I had a look at this forum and saw @Dan_Knight had referred to another image recently:
https://dietpi.com/phpbb/viewtopic.php?f=8&t=2317&p=8869#p8869
This image is about 250Mb and, i assume, contain the software of the image on the eMMC as delivered.

So, there is some confusion here and i sure hope you are enjoying your holidays rather than looking at forums. But, in the unlikely event of a rainy day…

Allo USBridge board
(John Aiello) #2

How did you write the image to the microSD card. You need to use Etcher to write the image. I am running my USBridge off a microSD card and used Etcher to write the image. 6.11 is the current build.

1 Like
(Mikael Ollars) #3

Yes, Etcher is used. The USBridge boots up just fine and i am accessing it with my iMacs Terminal application. The issues arise when i try o reinstall Roon Bridge (and removing the other claimed installs, such as Shairport et al)

(Sean) #4

Hi Mikael, that one is the non-Web GUI version. And that one needs to be configured via ssh. RoonBridge needs to be installed via dietpi-software ssh command.

This one that Dan linked is the Web GUI version and will have Roon Bridge working right away and you can configure via the web GUI.

1 Like
(Mikael Ollars) #5

Thanks Sean, but what i want to do is to run my USBridge from a pefectly clean DietPi image, just like all of my other Pi’s and 'tings! :slight_smile:
Problem is that the DietPi image from the Downloads section of dietpi.com “thinks” it has all the Allo GUI-software installed… But the packages are all missing from what i understand.
And i failed to reinstall Roon Bridge due to this error when i tries to APT Update:

LD_LIBRARY_PATH contains the traditional /lib directory,
but not the multiarch directory /lib/arm-linux-gnueabihf.
It is not safe to upgrade the C library in this situation;
please remove the /lib/directory from LD_LIBRARY_PATH and
try again.
dpkg: error processing archive /var/cache/apt/archives/libc6_2.24-11+deb9u3_armhf.deb (–unpack):
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.24-11+deb9u3_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

(Kai Mäkisara) #6

Sounds familiar. I did what the error message suggested:

export LD_LIBRARY_PATH=/lib/arm-linux-gnueabihf:/usr/lib
apt-get upgrade libc6
reboot

After this installing roon bridge succeeded (and it has worked since then). (Well, reading more carefully, the message just suggested to remove /lib from LD_LIBRARY_PATH, but the above was what I did.)

Another thing I did was to remove the ntp package (apt-get remove ntp). After this, the ntpd errors disappeared and my system synced time after boot. I had tried many things to get around this problem. So, removing ntp helped in my case but may not help others.

2 Likes
(Sean) #8

Not for Sparky… Unfortunately (for now).

(Dan Knight) #9

DietPi no longer uses NTP as was automatically removed in DietPi v6.9 update, systemd-timesync is now used and its more stable.

We have not changed the LD_LIBRARY_PATH variable on DietPi. So this is most likely an issue with Linux/APT, which is outside our control.

(Dan Knight) #10

This is not true, or the case.

The images contained on http://dietpi.com/download are the default DietPi net install images. Software is installed on demand via user run dietpi-software.

The images contained on https://dietpi.com/phpbb/viewtopic.php?f=8&t=2317&p=8869#p8869 are the pre-installed, ready to run Allo GUI images. These contain all the software as described in the information link below:
https://dietpi.com/phpbb/viewtopic.php?f=8&t=2317

(Dan Knight) #11

Please ensure your network is valid, and, your network/ISP is not blocking access to the time sync pool:
debian.pool.ntp.org

If problems persist, you can change the timesync mirror in:
dietpi-config > Networking Options: MISC > NTPD mirror

(Mikael Ollars) #12

I just redid an install of the basic DietPi image for the Sparky. Re-downloaded the image, and this time, dismantled the USBridge and then used Etcher to write the default image to the eMMC.
Everything went fine this time! Nothin’ reported in the Uninstall dialogue of dietpi-software.

Does the eMMC get mounted if i boot from a microSD in the external slot?

Very strange…

But nevermind, everyhing is working great now;
A light DietPi install on the eMMC with only Roon Bridge (and NetData atm)
A full ALLO GUI on an external micro SD for experimentation! Happy!
Thanks for following up @Dan_Knight!

1 Like
(Kai Mäkisara) #13

Yes, but at least some files remain in the image. Systemd-timesyncd refuses to start if the file /usr/sbin/ntpd exits and is executable. This example is from one site:

Condition: start condition failed at xxx 2015-07-10 15:17:56 CEST; 1s ago
ConditionFileIsExecutable=!/usr/sbin/ntpd was not met

I checked the SD card I used to re-install Dietpi to USBridge: /usr/sbin/ntpd exists.

I also experimented with my currently working installation. If I do:
touch /usr/sbin/ntpd
chmod 755 /usr/sbin/ntpd
I get the timeouts when toggling time sync daily/hourly. When I rm /usr/sbin/ntpd, the timeouts disappear.

Note that this applies to the Sparky SBC image from dietpi.com. I have also a Raspberry Pi and that image did not include /usr/sbin/ntpd (i.e., time sync worked).