Dietpi / Roon issues after updating to 151 and updating roon

Last night i updated dietpi to 151. I also updated roon to the latest rev and it asked to rebuild my index. After reboot I was able to see the Pi as an endpoint but after pressing play the songs in the album jumped from one to another and the album finished in about 5 seconds. Pressing play again resulted in a 'communication lost error message in roon. My dietpi had lots of errors on the screen and said a recursive fault detected and needed reboot. Tried this over and over multiple times with the same behavior.

I uninstalled roon from dietpi and reinstalled. After that process the errors were different. I could play a single song correctly but as soon as I clicked next song, the dac would loose lock on the PI and music would stop. selecting play or next song would not reestablish lock.

Options? reinstall dietpi fresh to my Pi? other ideas?



Ideally we’d need to see the errors what were reported during the update.
The issue reported isnt one we can replicate our end. Could be an underlying issue with PSU/SD card failing/insufficient.

reinstall dietpi fresh to my Pi?

Yep, unless we can get more information on the reported errors to assist with debugging, a fresh installation should offer a quick fix solution. However, if problems persist let us know.

what is the best method to pull the errors? can you point me to a post about how to pull these? thanks,


If the errors are on screen, you can either:

  • Take a picture of the screen.
  • If your running SSH, copy and paste the contents here.

If you can send me a bug report i’ll check system settings and see if anything stands out:

I could play a single song correctly but as soon as I clicked next song, the dac would loose lock on the PI and music would stop.

Also, when this occurs, lets check for critical errors with Roonbridge and USB dac:

systemctl status roonbridge -l
dmesg | grep usb

see next thread for updated issue information.

Hi Dan - I tried reinstalling dietpi and roon on a fresh sd card. with the same issues tonight. I also sent you a debug report through dietpi tonight using my new fresh install.

to elaborate further on the issue it may be with the sample rate conversion and my dac. i had roon set to DSD128 upsampling for months previously and working great . after the update yesterday i notice now my dac was showing 384 while causing the issues. After the reinstall tonight it would revert to 384 as well. Turning on the DSD upsampling on roon didn’t move the machine to D128 it still tried 384. trying to turn off the upsampling altogether seemed hit or miss as well. it play at 44 for a few seconds then stop playing. when i hit play again it would change back to 384

After playing around like that i finally also got the error message on the dietpi screen saying a restart is necessary.

During this process I validated the systemctl status roonbridge and it always says connected and running with no apparent errors. after this last issue i took a screen shot of these setting because my roon server cannot find the bridge alltogether. probably because it needs rebooting as discussed in the error message.

Roonbridgelog from early issues loosing dac connection:

RAAT server logs from early issues loosing dac connection:

final fault with message saying recursive error requires restart:

systemctl after last fault requiring restart:

if you need those with better resolution i can update them at higher res.

thanks much for you help.

1 Like


Thanks for the pics and bug report :slight_smile:

Looks like a hardware/kernel issue causing this. I can see from dmesg that the USB hub keeps dropping/failing, this is also dropping network connection and USB DAC.

Ok lets check a few things:

  • Which PSU are you running (eg: 5v 2.5A official RPi)?
  • Try rebooting the system, then straight away, remove the Logitech USB Receiver and all USB devices excluding the USB DAC. Then re-test for stability.

If problems persist, may be linked to the recent 4.9.30 kernel update we applied. We should try rolling back to 4.4 and see if its more stable:

#Install 4.4 kernel
wget -O
unzip -o -d /

I am currently using an Uptone JS2 power supply set to 5V using an adapter to convert to microUSB. A little overboard I know but it was laying around.

Recap of issue: Roon finds Pi as endpoint. content plays for about 10 seconds and then stops. Pushing play starts the song again but it stops after some time. Clicking next song starts the next song but will stop playing after some time. Clicking next song over and over will ultimately create an orange error on the roon screen ‘roon lost control of audio device’

What I tried:

  1. I tried removing the usb keyboard after restart. no change in behavior no other usb devices are attached to the pi.
  2. I updated the zip file for the kernel and rebooted. no change in behavior

Error messages after loading new kernel:

  1. serverctl looks clean
  2. Roonbridge logs look ok
  3. RAATserver logs show an issue. if you look at the photos you will see that my play > next song routine works sometimes but other times you see the error "error in snd_pcm_receiver: no such device (-19) which leads to output lost and it needs to reconnect.



Hi Aaron,

Apologies for the delay.

Yep, looks like the USB hub is still being dropped. This is the old kernel you would of been running for months without issue. Aside from the kernel, I cant see anything in our patches that would effect USB operation at hardware level.

Some things we should check:

  • Ensure USB contacts on USB DAC and RPi are clean
  • Might be worth trying the USB DAC in another USB socket on RPi (never know :slight_smile: )
  • If the USB DAC USB cable is changeable, try another.
  • Try a standard micro USB power supply for the RPi.

If still no joy, I think we should try a fresh installation of DietPi:

  • Writing a new DietPi image to the SD card.
  • Go through 1st run setup and install Roon Bridge
  • dietpi-config > Audio Options > Soundcard > USB-DAC

Thanks Dan.

The first thing I did after our initial discussion was the do the fresh install on a fresh SD card. No luck. thats the card I was using for all followup troubleshooting.

Heres what I have tried without removing fault.

  1. new install on new card, but I will do the dietpi-config like you said. I didn’t need to do that last time, it just started working
  2. new kernel install
  3. tried all USB slots, removed usb keyboard, validated my power supply connected and working ok.
  4. tried two different usb cables


  1. dietpi issue - looking less likely
  2. pi hardware issue - maybe powersupply related maybe usb ports
  3. dac hardware issue - i know that the optical cable works fine, maybe its the USB input.

Heres whats next to try:

  1. try connecting the roon server or tidal directly via usb from my server, to remove the endpoint from the equation
  2. try different USB dac
  3. try using different power supply for pi

Will update this post next week after I have tried some of these options. Cheers!!

1 Like