DietPi + Roonbridge do not appear in audio settings


I wanted to test RoonBridge at home but somehow do not seem to get it to work.

I followed the instructions for installing DietPi (install image on sd card), logged into my raspi pi via ssh, dietpi prompted me to install an update, then rebooted, then installed roon bridge successfully via entering the 3 recommended commands successively.

My RoonBridge is now running on my raspi 2 and is connected via Ethernet cable to my network.

I did not connect an external speaker yet, as I am missing a simple cinch cable (I want to attach the Roonbridge raspi via cinch cable to the aux in input of an active speaker).

I actually now expected to find RoonBridge as an audio zone within Roon audio settings.

Any idea what went wrong or how I could check if everything is setup right?

Hello again Kian,

What is your Roon Core running on? Can it play to other devices on your network?

I am only a beginner myself in this area but I presume you have pinged the Pi and it is visible on your network?

Whilst in a SSH session try the following commands

aplay -l
For audio string listing

systemctl status roonbridge -l
For roonbridge status

I presume that there needs to be an audio device connected for Roon to see the PI…? So you would need the onboard audio at least connected. I may be wrong though…!

Just checked:

Roon Bridge is running since 2 hours and when checking a play, I do not know what to look for but also everything looks fine.

My roon core is running on a NUC with Win10 and is able to find my amplifier which is connected to my router via Ethernet cable. My raspi is also connected to my router via Ethernet.

Regarding connection requirement: I seriously do not know if the raspi needs to be connected to my active speaker. And I also cannot test it as I cannot seem to find a stupid cheap cinch cable in my house.


Can you ping the Pi from your NUC? This will check basic network connectivity.

Please paste the Roonbridge status string here.

Please paste the aplay -l string here.

The audio device that needs connected for Roon to see it is the Pi onboard soundcard, or on a HAT or connected DAC. It sounds like you just have the basic Pi though, which should work provided you have the ALSA soundcard drivers installed. Roonbridge then has something to play to. Without a sound device to play to, I believe Roon will not see the Pi as an endpoint.

1 Like

just checked. Ping from my NUC was successful. Regarding the aplay string, though, it seems i had a typo yesterday when checking. how can i activate the soundcard?

Roonbridge string:

root@DietPi:~# systemctl status roonbridge -l
● roonbridge.service - RoonBridge
Loaded: loaded (/etc/systemd/system/roonbridge.service; enabled)
Active: active (running) since Wed 2017-11-15 19:20:46 UTC; 12h ago
Main PID: 412 (
CGroup: /system.slice/roonbridge.service
├─412 /bin/sh /opt/RoonBridge/
├─424 RoonBridge --debug --gc=sgen --server RoonBridge.exe
├─719 RoonBridgeHelper --debug --gc=sgen --server RoonBridgeHelper.exe
├─726 /opt/RoonBridge/Bridge/processreaper 719
└─955 RAATServer --debug --gc=sgen --server RAATServer.exe

Nov 15 19:20:46 DietPi systemd[1]: Started RoonBridge.
Nov 15 19:20:50 DietPi[412]: 00:00:00.013 Trace: [childprocess] using unix child process
Nov 15 19:20:50 DietPi[412]: Initializing
Nov 15 19:20:50 DietPi[412]: 00:00:00.591 Info: Starting /opt/RoonBridge/Bridge/RoonBridgeHelper
Nov 15 19:20:50 DietPi[412]: 00:00:00.623 Info: ConnectOrStartAndWaitForExit RAATServer
Nov 15 19:20:50 DietPi[412]: Not Running (.o)
Nov 15 19:20:53 DietPi[412]: Running
Nov 15 19:20:54 DietPi systemd[1]: Started RoonBridge.

aplay string:

root@DietPi:~# aplay -l
aplay: device_list:268: no soundcards found…

i’ll be damned. i went into the dietpi config and activated one of those available onboard sound cards (i went for onboard 3.5, or should I choose onboard HQ 3.5?).

aplay tells me the following now:

root@DietPi:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

but roon is showing me 2 new endpoints now - did I do something wrong? how can i reduce it to one?:

If you just enable the first one it should be the headphone socket on the pi. Connect up some headphones and stream some music to it.

haha, headphones, embarassing that i didnt have that idea.

headphones worked. I also bought a cheap cinch cable and it also works with my active speaker.

I am happy, but the noise coming out of the raspi is just horrible. I guess, I gotta opt for a DAC HAT if I want to fix this…

thanks for your help

1 Like

I now tried all default raspi soundcard options in dietpi (3.5/ hdmi oder forced 3.5 both basic and ultrahq options). regardless of which settings i select, I always have both Roon endpoints, although the second once does not work in roon (the one with HDMI).

now, it is a cosmetic issue, but still: how do i get rid of the HDMI roon option in the audio settings? i just dont want it to show up at all. is there a setting within dietpi that i need to edit?

Hi, in dietpi-config I recall there is an option to disable HDMI, so that should do it. You will have to find it in the options menu though.

hmm, i do not find the option to disable hdmi directly, i rather found the option within Display settings -> resolution to go “headless”. the description says that it will disable “hdmi & composite output”. when going headless I still can see the hdmi device within roon’s audio settings. I also set PSU noise reduction to enabled which also says that it will disable hdmi output.

did i miss something?

The audio driver on the Pi is shared between 3,5mm and HDMI. DietPi can route a preference for output, but Roon will still be able to see the other.

Please note that Pi on-board audio is abysmal. It is fine for a proof-of-concept (as in your case), but not meant for human ears. :wink:

If you’d like to pursue the Pi as a Roon audio zone, add a DAC HAT (the Allo Boss is great at $59). When selected, DietPi will no longer load the on-board audio drive, so you will only the the HAT in Roon.


Hi Rene,

thanks for clarifying. makes sense.

indeed, it is a proof of concept, which is why I now ordered a hifiberry bundle (raspi3 incl. amp 2 HAT) to revive my old passive bookshelf speakers.

I agree with you that sound is abysmal when directly connected to raspi 2. it is maybe the best way to demonstrate hifi newbies what we mean with “abysmal sound”:slight_smile:

I will check out the DAC HAT you suggested and decide which DAC HAT to get for my current active speaker.

thanks a lot for all your help here.


ok, just a quick update, as i finally received my hifiberry dac+ pro (long hassle with customs office who apparently thought i am importing illegal stuff, as they were not aware what a raspi is).

i connected the DAC HAT, easily configured it within dietpi et voilá, it works flawlessly. needless to say, the sound quality is just great with my active external speaker. it is just a great hands on case for anyone who does not understand “good vs bad sound”…

and yes @RBM, you were right, I only see the HAT as endpoint, which is great!

unfortunately, i do not have time to setup and check my AMP HAT, which I need to connect to my passive speakers. gotta visit the family during holiday season… but update will follow, preferably prior to new years eve :slight_smile:

1 Like

and here comes the next update:

  • I setup the new hifiberry AMP 2 with a RPI3 and a strong PSU
  • configured the hifiberry AMP 2 in dietpi as dacplus (the AMP soundcard option is only suitable for older geneartion AMP HATS by hifiberry)
  • the hifiberry AMP delivers very nice sound quality

I only have 2 open points:

  1. RPI3 onboard wifi seems to be crap. Roon sometimes recognizes it and sometimes not -> very unstable although i tried placing it 3m away from my router.
    1.1 Any advice how I can realize Wifi streaming with this setup? I can live without wifi in 1 room as I can connect via ethernet. but my other room relies on wifi streaming
  2. I am using 1 speaker per RPI AMP HAT Combo. Does Roon automatically recognize that I am running it in Mono instead of Stereo? Or do I need to make other settings as well?

RPI WiFI is a small chip on a low-powered board with no antennas. This situation is not helped by adding HATs and/or cases. There are a number of USB-WiFi adapters that people reported success with. I use a last-gen Airport Express as bridge to a Cubox – works flawlessly, even in high bitrates.

For 2. you’ll want to downmix your output signal to mono – you can do that using Procedural EQ in Roon. This explains how:

Final Update
WiFi Issues resolved:

  • my USB Wifi Adapter arrived
  • Setup was easily done via the dietpi config interface (just disabling on-board wifi and enabling wifi)
  • Musik streams flawlessly without any dropouts

Mono Playback:

  • Set it up as advised in the post
  • sounds better

Thanks @RBM !!!

1 Like