DietPi update 6.7 > 6.11 fails on Sparky/USBridge

(Mark) #1

Hi all,

I’m trying to update dietpi from 6.7 to 6.11 but not having any luck. I am a complete novice with CLI and SSH but I have managed to login to my USBridge but I get stuck when I try to run the dietpi-update command.
Please can someone drip feed me as to what I should do?

Any help would be greatly appreciated.

Allo USBridge board
(Mark) #2

Think I may have worked it out, needed to type su - to get root

Just trying the update now

(Mark) #3

Nope, not happening, just getting this…

![31|548x500](

(Sean) #4

Hey mate

It looks like you logged in using dietpi@ipaddress

See the info at the DietPi ‘getting started’ site:

https://dietpi.com/phpbb/viewtopic.php?f=8&t=9#p9

https://dietpi.com/phpbb/viewtopic.php?t=1621#p6596

So you login using “ssh root@ipaddress”

You might be able to do it that way now or given the current state (your screenshots) it may be best to download a clean image and install a clean copy from scratch. Go through the 2 links above for the step by steps.

The Allo USBridge site has the links to the Web GUI image to download and burn to either eMMC or microSD card

Hope that helps

(Mark) #5

Ah, shoot. I tried again with root@DietPi:~# and it just does the same thing as above.

Those instructions on the Dietpi website give me a headache, I don’t have an SD card or card reader.
It’s still working but just won’t update.

(Scott Houston) #6

If you’re logged in as root via SSH, you shouldn’t need “sudo” in front of “dietpi-update”. Not sure if you are typing that or not. Shouldn’t make any difference, but you never know.

And you have internet connectivity? I think it’s looking for a time sync to the outside world.

(Mark) #7

Hi Scott

I didn’t use “sudo” once I had worked out how to log in as root.
I am also connected to the internet.

This is my current terminal before I start the update:

(Sean) #8

Eeep!

I’m an expert an breaking things and then doing a install/fresh install.

I’m only half decent at following pre-determined steps with the command line stuff. Beyond that I’m pretty clueless.

We might need to tag Mr DietPi himself, @Dan_Knight for his expertise if you don’t have access to a card reader to do a clean install.

Looks like Scott is another Aussie too? Maybe when the other continents wake up someone can help out.

1 Like
(Scott Houston) #9

OK. Am googling. Will see if I can help.

(Mark) #10

Thanks Gents, much appreciated.

I’m googling as well but have to walk away to put my son in the bath.

(Sean) #11

Be careful multi-tasking mate, or else the next problem will be a dropped iPhone in the bathtub :grin:

1 Like
(Sean) #12

If you’re as clumsy as me, I’d definitely pickup a card reader if you can (for future use).

The clean install process becomes easier after the first couple times and handy when things go wrong. Just means you don’t need to wait for Allo/DietPi Support (timezone differences) for most things, where installing from scratch fixes things.

2 Likes
(Scott Houston) #13

Kiwi, technically, but crossed the ditch (Tasman sea) a while ago (in fact, when dial up was still a thing).

2 Likes
#14

Looks a bit like the issue I had a while back … DietPi + Allo Web GUI: Now available

Have you considered just flashing the latest image rather than updating…

2 Likes
(Scott Houston) #15

Splish, splash.

Found this: DietPi + Allo Web GUI: Now available, which lead me to this: https://www.computeraudiophile.com/forums/topic/43628-allo-gui-image-broken/?tab=comments#comment-832007

Just jump straight to the last one to see the workaround (quicker than doing a new image). Credit to @wakajazz for addressing originally.

2 Likes
(Mark) #16

Thanks @Scott_Houston @Wakajazz @Sean2016, just about to sit down for my evening meal and a beer so I probably won’t touch this until tomorrow. You are all legends.

Maybe @andybob, @RBM or @Rugby could create a new thread for my update issue instead of cluttering this one up.

Cheers

1 Like
(Rene Bouwmeester) #17

I just split off the conversation and moved it to the DietPi forum.

I have good hope that the procedure linked to by @Scott_Houston will help:

v6.6 upgrade to 6.9 one option is dietpi-config ->advanced options -> time sync mode -> disable
then do dietpi-update.
in between 6.7 to 6.8 update fails ( select exit) , password change options selected cancel , then will complete update to v6.9

If not, perhaps @Dan_Knight can sprinkle some wisdom on your woes?

4 Likes
(Mark) #18

Thank you RBM,

Just updating now, hopefully it works this time.

Cheers, I’m off for a beer and some homemade Buffalo Mozzarella Lasagna :smiley:

1 Like
(Rene Bouwmeester) #19

Sounds great. I’d gladly fix your endpoint in exchange for a bite & sip. :wink:

(Mark) #20

You are welcome to pop over RBM, won’t that be a treat when they finally nail Matter Transportation :grin:

My wife’s Lasagna is the best, the mozzarella and star anise in the sauce is what takes it to the next level.