Difficulty connecting my Nucleus + to my network

Core Machine

Nucleus +

Network Details

Audio Devices

Description of Issue

I am having trouble connecting my brand new Nucleus + to my internet via the router.

I get the following message

“Network error: Please check your internet connection”.

I have, of course checked the connection (it is working with everything else I have connected). I have changed my cables and bought brand new LAN Cables. I experienced the same problem when I first attempted to connect the Nucleus, so took it back to the dealer. They had no problem and were able to update the software so it has edition 1.8 installed.

Unfortunately, once I got the Nucleus home again, I received the same message. Any suggestions why this might be when all my other devices, including laptops, i-pads, Hi-Fi systems, Apple TV’s etc have no problems. This is really frustrating so any advice you can give me would be most appreciated.

Thank you,

Have you tried to connect the Nucleus at another port / outlet? Or maybe connect a laptop where the Nucleus currently is plugged in and see if that machine can work ok?

Hi @Warren_Pescod,

I’ve added in the pro-forma headers into your post, could you update the networking section please.
Make sure you describe your networking equipment and how it all connects.

From the Nucleus’ web interface, have a look whether is it setup to use a DHCP or Fixed network address. I recommend changing this to DHCP and then rebooting the Nucleus.

When the Nucleus is connected via RJ45 lead to you network, what LEDs light are on / flashing on the ports?

Dear Carl,

Many thanks. I have determined that the issue seems to be that the DHCP connection has a different ISP address from the DNS address. I have checked the port lights on the Nucleus + and one the router . On the former, one is flashing green, the other orange. On 4th latter, both flash green.
From other threads, a mismatch between the addresses seems to cause a communications problem. I have been in touch with my technician and I hope he will be able to help me resolve it. In the meantime, I will try what you suggest to see if this helps.

Bernd, Thank you also. Yes, I tried this without making any difference. But as I indicate above, I think I have been able to identify the problem.


Some basics:

The DHCP server(!) provides DHCP clients (like your Nucleus and your iPad) with a valid IP address, and a DNS server address. Well there is more, but not needed here.

The DNS server (means that service to translate names “www.google.com” to IP address “” whatever, that actually can be reached) should be the same all over your network. Most likely it’s your router which then uses on behalf of say your nucleus and sends him the result. Different DNS server entries around your network maybe aren’t s/th one would wish to have. Keep it simple.


Thank you. This is exactly what I need to know for when I meet my technician. The difference between the IP address and the DNS address confused me.


Hi @Warren_Pescod

I’d set your router to use Google DNS — We’ve seen it help in the past with issues like this.

If you’re still seeing issues, can you provide some information about your network? What kind of router are you using? Any other networking gear in play here?