Directstream BridgeII disappears / connection lost

I have roon core running on one of the latest iMac multicore machines. It is streaming to a Directstream DAC using the BridgeII card. Whenever I listen to music, particularly MQA at 192Khz, the BridgeII will disappear as an output device after about 20 minutes of use. If I restart Roon software, the BridgeII does not reappear as an output device. The only way to make it reappear is to hard boot the Direcstream DAC, itself.

This would suggest it’s a networking issue of some kind but don’t understand why rebooting the Roon core software doesn’t solve the problem, particularly when the Directstream DAC is visible to other devices (even when invisible to Roon). For example, prior to using roon, I simply used the mControl iOS app to stream Tidal directly to the BridgeII on the Direcstream. This still works, even when the DAC is no longer visible to Roon, so something fishy is going on and I don’t know what.

Your help would be appreciated, as I am still trialling Roon. If I can’t sort this out, I will not subscribe, as I was hoping to use Roon exclusively for Tidal Masters to Directstream usage.

Thanks.

@support any ideas?

Hello @David_Wilson,

Thanks for contacting support, I’d be happy to take a look over this issue for you and get your setup running as soon as possible so that you can properly evaluate Roon. I have gone ahead and enabled diagnostics mode on your account and what this action will do is next time your Roon Core is active, a set of logs will automatically be generated and uploaded to our servers for further analysis.

I kindly ask you to reproduce this issue you are facing and let me know the exact local time time in your country that the Bridgell disappears (ex.1:30PM). If you could please provide those timestamps, we can check to see if anything is going wrong with Roon around that time and suggest some further troubleshooting steps here. Please let me know the above when possible.

Thanks,
Noris

It occurred today at 11:02am PST

Hello @David_Wilson,

Thank you for providing that timestamp for me. I can confirm that we have received the necessary diagnostics from your machine and I have started a case for you with our QA team to identify if there are any errors being reported around that time. I appreciate your patience while this investigation occurs and I will be sure to update you once I have more information to share.

Thanks,
Noris

Hello @David_Wilson,

While the QA team investigates this issue, can you please provide an overview of your network setup? Please include the model/manufacturer or your Router, any switches, Access Points, Range extenders, ect.

Can you please let me know how your devices are connected to the Router? Are you using an Ethernet connection for your iMac or WiFi? Is the Directstream/Bridgell using Ethernet and connected directly to the Router or another switch in between? Please let me know when possible.

Thanks,
Noris

Thanks for looking into it. I have wondered, myself, if there could be an issue related to networking but I haven’t seen problems like this before. For instance, I used to be on a slower network and when the Bridge couldn’t get data fast enough, it just stopped playing; it didn’t ‘disappear’ from the network. So, I’m not sure why this is happening now. I wonder if the Bridge is unable to buffer correctly?
Okay, my Bridge is connected directly to a Amplifi mesh router, as are the other components in my audio system. The Mesh router communicates with another mesh router a short distance away, which is plugged directly into my Xfinity cable ISP box (300Mbps). the routers are in bridge mode, so they are not using NAT. DHCP is provided by my Xfinity box.
When I run a speed test over Wifi, I get about 175Mbps down and 11.8Mbps up.
My Roon system is being served by a MacOS desktop (latest 2018 iMac with multiple cores) and that is plugged into the same router as the bridge, so they are both using Ethernet (on the same mesh router) to communicate with one another. So, if I understand correctly, the Roon software is fetching the MQA files from the Internet (over Wifi from the mesh router) and then sending those files over Ethernet directly to the Bridge (using that same mesh router). If there is a buffering or networking problem, wouldn’t it be because the Roon server software is dropping out and not providing the Bridge with data fast enough and, if so, it should be doing a better job of buffering the data before sending?

Hello @David_Wilson,

Thank you for providing that network setup for me, I have gone ahead and forwarded it to the QA team reviewing your case. They have not completed their initial report yet so I comment on exactly what could be going wrong here, just do know that we are looking into it. As for this part of your post:

The MQA files would be fetched from the internet and then sent over our RAATServer protocol to the Bridge, and we use Multicast to communicate with devices which is an operation done over your network, even if they are plugged in via Ethernet directly to your Bridge.

There could be a number of factors here at play, including the networking environment or something preventing Roon from properly communicating with your device and the QA team is currently investigating as to where that issue lies.

I will be sure to let you know once they have finalized their report and have passed it on to me, I appreciate your patience while our investigation takes place.

Thanks,
Noris

Hello @David_Wilson,

The QA team has requested some more information regarding this issue. They would like to know:

  • When have you first noticed this issue, was it imminently visible or did this occur only after a few days of usage?
  • Do any of your other zones disappear as well or is this localized only to your Directstream DAC? Do you have any other DACs around the house that you can temporarily verify if they exhibit this same behavior?

Please let me know when possible.

Thanks,
Noris

P.S. Please check your PMs

Hello @David_Wilson,

Just wanted to check in with you here, are you still experiencing the same issue as before? Can you please let me know your replies to the previous questions when you have a chance?

Thanks,
Noris

Sorry, I’ve been travelling for a week.
Ok - the issue was imminently visible. I installed Roon on my MacOS iMac desktop and connected it to the Bridge (after updating the Bridge firmware). As soon as I tried playing music to the Bridge, it would disappear.

I only have the one DAC in the house. I have a BluSound player connected to the DAC as well, so when the Bridge stops working, I use that instead. My main reason for wanting to get this to work is so that MQA files will play directly through to the DAC over the Bridge and I’d get maximum resolution.

It seems to me that 192khz music files are the worst - they quit out almost immediately (Bridge disappears). If I play something of a lesser quality, it might play for about 5-10 minutes before the Bridge disappears.

Hello @David_Wilson,

I took a look at your logs and was able to identify the behavior you were describing. So far, we have not been pin down the reason for the disconnects you are seeing, Roon is behaving normally as far as we can tell. Here is a portion of the logs showing the disconnect

07/12 11:02:26 Trace: [Living Room (Bridge)] [Enhanced, 24/48 MQA TIDAL FLAC => 24/48 MQA] [100% buf] [PLAYING @ 0:55/4:47] Eyes Be Closed - Washed Out
07/12 11:02:28 Info: [stats] 6507mb Virtual, 1592mb Physical, 471mb Managed, 88 Threads, FDs
07/12 11:02:31 Trace: [Living Room (Bridge)] [Enhanced, 24/48 MQA TIDAL FLAC => 24/48 MQA] [100% buf] [PLAYING @ 1:00/4:47] Eyes Be Closed - Washed Out
07/12 11:02:31 Trace: [Living Room (Bridge)] [zoneplayer/raat] sync PS Audio DirectStream DAC: realtime=60987655666 rtt=1000us offset=-80958344us delta=275us drift=9870us in 61.111s (161.520ppm, 581.473ms/hr)
07/12 11:02:32 Trace: [raat] [PS Audio DirectStream DAC @ 10.0.0.164:44541] => Disconnected
07/12 11:02:32 Trace: [raat] [PS Audio DirectStream DAC @ 10.0.0.164:44541] lost client connection. Retrying
07/12 11:02:32 Trace: [push] restarting connection (Unable to read data from the transport connection: interrupted.)
07/12 11:02:32 Trace: [push] retrying connection in 9557ms
07/12 11:02:32 Trace: [raat] [PS Audio DirectStream DAC @ 10.0.0.164:44541] connecting (attempt 1)
07/12 11:02:32 Warn: [raat_ll/client] [PS Audio DirectStream DAC @ 10.0.0.164:44541] failed to connect Connection refused

What you are seeing here is that at the beginning of this trace, playing sucesfully with a full buffer on the device. Then, as we try to reconnect to the device to do a status check and clock sync, the connection can no longer be opened and playback resultantly fails.

This behavior can be caused by two things, network conditions or issues at the endpoint. While we can see here that the throughput to the device is in good shape (we can tell by the fact that you have a full buffer), this sudden drop in connection may occur if there is a change in the network such as DHCP reassignment or mis-applied multicast routing. You may want to investigate the multicast settings on your router/mesh system, often we see issues like this resolved when users toggle their “IGMP” settings.

The other possibility is that this behavior is a result of an issue at the RAAT endpoint, in this case the Network Bridge II. It is possible that the RAAT code as configured on the bridge may be mis-behaving in some way that does not effect the other network streaming services running concurrently on the device. I would strongly recommend reaching out to PS Audio and getting their take on what you are seeing, unfortunately I do not have the capability to request diagnostic logs from other manufacturer’s devices.

I apologize that things aren’t working correctly out of the box for you. We’re here to help however we can and hopefully we can get things up and running for you without any further frustration.

-John