Disable the new mouse wheel smooth scrolling in Roon 2.0 on Windows?

I don’t see an option to disable it.

Hello?? I can not browse Roon with this ANNOYING SMOOTH SCROLLING!
I get dizzy because this smooth scrolling is very UNNATURAL!
I unchecked all options in Windows 11 that could make a difference, but it does not.

Probably a video of what you are seeing would help.

No, it won’t.
I need tech guys to respond and remove this idiotic windows smooth scrolling or atleast an option to disable it. It wasnt there in Roons previous version.
This will not make me buy another 1-year subscription next time.

Ok enjoy.,…

All the technical staff is on vacation or something? Why do I have to wait 3 days to get a response that says it will fix my isue?

a) you’ve posted your complaint in the #roon category of the forum which is for general discussions of the Roon software. If you want support from the Support Team, then the place to post is in the #support category of the forum, and
b) in case you hadn’t noticed, the queue of support requests is fairly large at the moment with people trying to get the large number of permutations of ISPs, routers and networks sorted to get ARC running.


Ok thanks. I will just downgrade to Roon 1.8 meanwhile so that I will have normal scrolling again.

Smooth scrolling was a much-requested feature and is common on Windows apps today. We’ve fielded complaints for years that Roon felt like it was from 2002 because it scrolled like apps from that era.

That has been fixed for Roon 2.0. We have no plans to make it an option at this time. If you can’t stand the sight of it, feel free to use 1.8 Legacy.


Well, another problem is that the smooth scrolling is not smooth at al sometimes. It hangs/stutters often while scrolling. So this is not consistent at all. Very annoying.
So can you please make an option to disable the “smooth” scrolling atleast? Since it does not work proper at all. Aside of the fact that not all people like this smooth scrolling.

This would be fine if smooth scrolling was actually smooth.
But on my iPad and Windows remotes, scrolling down Albums and Artists suffers from considerable stuttering. On some other pages, it seems to be better.

This is on non-ARC 2.0. I didn’t see such stuttering issues with 1.8.


Exactly. So there needs to be an option to turn off this “smooth” scrolling in Roon because I actually want things to run smooth from A to Z. Even more because I am paying a lot of money for this Roon software. It would be an easy fix to just implement an option to turn off smooth scrolling.

Sounds like a Feature Request now.

Without knowing Roon’s architecture and components used across all platforms, it seems hard to judge that it “would be an easy fix”

1 Like

All smooth for me on all platforms.

To me this is not a feature request. It’s a fault, or at least an incompatibility with some remotes.
On my latest gen 2022 iPAD AIr, the stuttering is so obvious that it would not have got past the most basic alpha test. So there must be some setting or incompatibility or something that is causing it to be terrible in some cases and ok in others.

The smooth scrolling that @Penny is talking about only was implemented on Windows when using a mouse wheel.

So, there are two separate scrolling issues. My issue is not related to a mouse wheel. But it occurs on both my iPAD and my Windows 10 laptop, so it can’t simply be a rare, one-off situation.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.