Discography not loading for some artists [Solved]

Roon Core Machine

ROCk on NUC8iBEH, 4gb RAM, 128gb SSD

Networking Gear & Setup Details

All wired, ethernet

Connected Audio Devices

Ropieee on Pi4, local library SSD connected by usb to rock.

I use iOS and Android control apps.

Number of Tracks in Library

32,000 tracks

Description of Issue

I have had an issue since build 936 when certain artists discography don’t load. For such artists I just see a couple of grey boxes. Qobuz is my subscription service.

Example artists include the mars volta, elbow, dead meadow. There may be others, I haven’t been through every artist. For each of these artists I have a mix of local only/streaming albums.

Below is a screenshot of what I see for dead meadow:

I have tried restarting all hardware with no joy. I can’t see any pattern as to why certain discographies don’t load.

Any help appreciated. :slight_smile:

Hey @James_Hobson,

Thanks for getting in touch, we’re sorry to hear that you’re having some issues with your artwork in Roon.

I pulled your logs and found error messages indicating that you may have been having Qobuz login problems.

05/14 17:56:38 Warn: [qobuz] [http] error result from http request: {"status":"error","code":401,"message":"Invalid username\/email and password combination"}
  • Can you please try signing out of Qobuz in Roon
  • Reboot your Core and Router
  • Then attempt to log into the Qobuz webplayer with your login and password.
  • Check to ensure that there aren’t any issues with your account
  • If everything looks good there, log back into Qobuz in Roon using the same credentials you used for the webplaer.
  • Please let us know if this helps!

Hi @jamie

Thanks for getting back to me. I have followed those steps and unfortunately it’s the same result.

Weirdly, if I select the filter in discography it shows results (see below). And the overview shows all the albums in my library including Qobuz.

Any other ideas?



I am experiencing this same issue. One artist for which the problem is apparent every time is Peter Cetera. Any ideas as to how I might fis this issue would be much appreciated.

@jamie just to confirm this hasn’t resolved with latest build (952)

I’m experiencing the same issue. Artists Marillion and Liam Gallagher.
Edit: Oasis too

@jamie just adding more artists to the list:

U2, The verve, leaf library, wand.

If I search these artists albums appear in the results from qobuz. And if I sort by recordings in the discography section tracks appear. It’s just albums that don’t show.

Build 970 did not solve this for me.

I see this now with release 1.8-970:

Unfortunately still an issue for me:

Yeah. I’ve noticed it is affecting different artists for different users

@James_Hobson @Bolus Does it not come at all or only very delayed? Some said to clear the cache brings remedy or speed. I have not had to try it yet.

Is perhaps a very small memory in the phone?

It does not come at all. Also it’s not limited to my phone. On all remote devices it’s the same for the same artists. So It’s something to do with the core (synology ds218+, Roon in docker container) or the roon software in my assessment . Restarting the core does not fix it. Nor does clearing the cache.

@Uwe_Albrecht my experience is exactly the same as @Bolus , although I have an NUC ROCK

@James_Hobson and @Bolus I wish you the Support can investigate it thoroughly, test possible solutions and then fix it with a few lines of program code.

Not everything is due to the code and then affects everyone.

Sometimes other drivers must be installed directly from the manufacturer, sometimes a virus scanner must be uninstalled, a firewall setting must be adjusted…

Have you tried disconnecting and reconnecting Tidal/Qobuz ?

The discography only works if you have a service connected , if that’s slow for any reason this may cause what you are seeing

Maybe just reboot everything (network included) todays build looks a lot quicker to me

Thanks @Uwe_Albrecht @Mike_O_Neill

I’ve tried rebooting everything, logging in/out etc. As mentioned it’s a strange issue as it affects only some, seemingly random artists, most are fine. And differs user to user.

This has only become an issue in the last 2 months. Before that no issues for 2 years.


Just a thought, are they pictures of Roon or your own pictures?

Another thought: There are fantastic image resolutions of many megabytes, which can actually only look richtg good on 4K screens, other devices rather weigh down with unnecessary and not visible things.

They are mostly roon images but some artists have local none qobuz albums.

The thing is the album artwork loads everywhere in roon (e.g artist overview, my library > albums, search), it’s just the discography section that doesn’t load anything.

Hi @support,

Just an update, this is not getting better. I noticed new artists this affected recently, one being Atlas sound. Last week the discography loaded, now it doesn’t. Is there anything that can be pulled from my logs to see what’s going on here?