Disconnects from core

Since a few days, Roon frequently (4 times or more an hour) loses the connection with the core. It’s not the internet. I suspect it’s the app (1.8 android). My core is on a Nucleus Rev B. I chose the expensive nucleus solution, hoping to avoid problems such as this… So far, it happens while streaming Qobuzz, don’t know whether it also happens when playing files on the NAS.
It’s strange that this should start happening suddenly, because absolutely nothing has changed in my system. It happens regardless of whether the Naim streamer is wired or connected via wifi.

I just noticed that it also happens when returning to Roon app after doing something else on the tablet (such as reading this forum). Apparently the app has to wake up, which was always so, but it used to just go on where it left off, while now it disconnects from core. My tablet is 5 years old, android 8.1.0. It doesn’t have the option of keeping an app in memory. Should I buy a new one?

Hi @Leo_Reijnen

Do you have any other remote devices that you can use as a test? Do they also exhibit this issue?

When you say the app loses connection to the Core, is it able to reconnect after this or is it unable to find the Core at all?

Hello Dylan. Thanks for replying so swiftly. Yes, I have an android phone and will try that as well, and report back here.
And yes, the app does automatically reconnect to the core and remembers ‘where it was’, although playback is on pause. It’s really a very annoying problem, as it thoroughly ruins the listening experience, as you can imagine.

Using my android phone seems more stable
As I had only one disconnect (after an hour of being on pause).
Does anyone know which android version on what brand of tablet has the option of locking apps in memory? It seems there are many flavours of Android floating about…

Unfortunately, I’ve now also had a few disconnects from core while using my Android phone as remote. And in another room, where the nucleus actually is and connects via USB to a DAC, and I use a Win10 PC as remote, the same thing happened twice within an hour.
So, the disconnects are not exclusively associated with one particular remote. In all cases, I was streaming from Qobuzz. But if the fault lay there, would that result in the same error message? If not, that leaves only the core as the culprit, it seems. I don’t think it can be the internet connection, as I get no log messages from, for instance, the NAS about any interruption of service.
So, mystery abounds… any and all advice is appreciated.

I am having the same situation. Over the past few days my roon core has disconnected numerous times. I have two systems; one is controlled with iPad, the other with Macbook Pro laptop. My core is running on a Nucleus hard wired to an Apple router going through a Netgear switch. Both my main system and bedroom system go through this switch. Roon just stops, music stops and eventually reboots back to the album that was playing when disconnected. This has happened at least six times in the past two days. Any advice??

I can report that I’ve had similar issues. I just started using Roon so I can’t report as to how long the issue has persisted. Several times a day though I will be in the middle of playing a track on my M1 Mac Mini (16GB) and it will suddenly give me the message stating that the connection has been lost to the core (virtualized 6-core i9 w/ 8GB). Quick ping test shows 2ms response time to the server uninterrupted.

I’ll see if I can keep my iPad running and check to see if it also shows the disconnect.

Yesterday, there was a firmware update for my Naim streamer (some bug fixes regarding playing Hires on Qobuzz were mentioned) and I haven’t had any disconnects from core since. Fingers crossed…

Alas! Two more disconnects from nucleus core last night within the time span of one album, while streaming from Qobuzz using Android app on Samsung tablet.

Roon 1.8 build 778
Core: Nucleus Rev B
Endpoint: Naim ND5 XS2
Connection: only wired ethernet on Cat5 and Cat6 cables
Router: Draytek Vigor 2133
Switches: 2 x Netgear 1Gb ProSafe GS 108
Internet: 100 Mbps via glass fibre

Unfortunately, I am still experiencing (too) frequent “lost connection to core” incidents while streaming Qobuzz.
So, I’m trying to pin down the cause, find the culprit, cure the patient. I figure it can’t be the android app, as under normal playback circumstances I can close the app and the music will continue.

First question: does “losing connection to core” literally mean just that? And why doesn’t it say ‘what’ is losing it? Logically, I would assume that the message means that the connection between the core (on the Nucleus) and the endpoint (the Naim) is broken. But can it also mean that Qobuzz has a hick-up, or my Internet connection? Or, could the app still play a part in this? I’m just trying to understand how the chain works. The connection path is: Nucleus->switch 1->switch 2->Naim. The app hovers somewhere in there via WiFi, but does/can it actually control the physical connection? Are there any log files to consult (sorry, relative newbie with Roon).

I would dearly appreciate advice on what steps to take to identify the weak link in the chain, as this whole thing seriously spoils my listening pleasure, as all audiophiles here probably can imagine. I am totally immersed in a piece of music and BANG!.. silence. The app quickly recovers and connection is restored to where I was in the music and I just have hit the play button to continue, but my concentration is broken, of course.
So, help anyone? Support? I’m not the only one with this problem on a theoretically rather perfect setup and I’ve been posting about this for nearly a month now…

Oh I love to be alone in the country… I feel like I’m talking to myself here. Oh well, I’ll just update myself then. As an experiment, I only listened to local files for three days and have had no “lost connection to core” errors at all. Will try Qobuzz again and am beginning to suspect the fault lies there. Will keep myself posted. Don’t mention it, I’m welcome.

Yesterday and today listening to Qobuz again. No hickups so far. Let’s hope the problem has solved itself miraculously.

I’ve been listening to Qobuz now for almost two hours without any disconnects from core, since updating to 806. Fingers crossed…

I can now report having had ZERO disconnects from Nucleus core when streaming Qobuz via Android tablet since the latest update. Hooray! And thanks so much for solving this issue! What was the cause/solution?