Display off - remote can't find core

Core Machine (Operating system/System info/Roon build number)
WIN 10 PC / Roon 1.7 build 521

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Squeezebox touch via WiFi and Onkyo AV receiver via HDMI

Description Of Issue
I have recently reinstalled the Core PC with a fresh Win10 install.
After that, I have this problem: when the PC display turns off, it happens that the remote devices (android mobiles and another win 10 laptop) fail to connect to the core machine.
Note that, if music is playing via WIFI to the squeezebox, the stream continues with no problem: the core PC is not sleeping, and Roon is on and working normally. I just cannot connect to the core via the remotes. If i turn on the display (moving mouse), then the core immediately appears on the remote.
One additional info: i have set the win10 pc with the defauld balanced power plan (desktop pc, not laptop).

The behavior is different from what happens with the HDMI connection: in that case, when the display turns off, the music stops. But this used to happen also with the previous win7 OS, and is a limitation of the HDMI connection in windows…
The Wifi problem, though, is completely new.

I’ve looked on the forum, but i could not find infos. Sorry if this has already been reported.

Hi @Niccolo_Terzi,

This sounds like there might be an issue with the sleep settings / power saving settings on the machine that is preventing the machine from being available on the network to other devices. Can you share some screenshots of your current sleep / power saving settings on the machine?

See also the following links to find out about other places you can look at. Also check that you are using the most recent drivers – from the device manufacturers; don’t trust Windows Update.


As i said, the streaming continues with no problem… that means that the LAN is on and that the machine is available to other devices (at least, it is available to my squeezebox, connected via WiFi to the router).
But the core machine cannot be found by the remotes.

@BlackJack I’ve checked the link, and i’ve unchecked the power option for the LAN controller. I’ll see if this works.

@dylan the sleep settings in windows are quite lengthy… in my case, they are now the default win10 settings (balanced) for a desktop PC. it can be that in the previous OS they were different and made no trouble…

i’ve changed the LAN power settings (DO NOT allow the device to be turned off to save power) but the problem is still there.

Do you have other server software on your machine (like e.g. MinimServer)? Does this Software behave the same (keeps outgoing connections alive but is unavailable for new incoming connections)?

Update: Might not be a useful test as this is Java software (all one thread) whereas Roon is split in parts.
@dylan: Serving music is done by RAATServer.exe, the non working connection from remotes should be answered – if working – by RoonServer.exe; is this correct?

Is there a change in behavior if you completely turn of power saving (change to a according plan)? And if so and you later then modify that plan to just turn off the monitor, does it still work? You may have to manually turn on power saving features until you find the one that triggers the erroneous behavior and then search for a solution.

Note: Windows 10 is a desktop OS. If power saving is allowed and kicks in and the desktop is no longer displayed (screen turns off), windows might turn of processes or restrict resources (RAM, processing time) at will to save power (actually as defined in the power plan). This might lead to all kinds of undesired behavior if a PC is used as a (semi / pseudo) server. One might have to give up on power saving to keep background server processes alive.

I have changed the power plan ad to not turn off the display (so, without changing anything else). but i could not check if everything works … as this is also my work PC, and… i’m working.

I have checked now. after the change in the display turning off in power management, the remotes can find the core.
i have not changed the overall power plan (balaced vs performance vs power saver): i have kept the default balanced plan, changing just the display setting.

Are you using the all-in-one Roon install? Maybe the display turn off, which often goes along with limiting GPU resources / turning off GPU, might lead to problems with the GUI component of Roon that leads to the problems that you described and using the separate server install might fix this. But this is just some guessing on my side – Roon officials would have to confirm if this is a possible reason / fix for this behavior.

Hi @BlackJack
i don’t know if i understand the question. do you mean if i’m using Roon vs Roon server? the answer is Roon. i used it also with win 7 (unchanged hardware) and had no problems.
i would avoid now to make another install of roon server…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.