Display to Chromecast No Longer Working

Intel NUC i7 running ROC
Google Wi-Fi Router

Bel Canto Dac3
Chromecast to Roku
100K tracks

My Chromecast used to show up as a display no problem. Since updating to Roon 1.8, I no longer see my Chromecast in Settings–>Display. I confirmed my Roku and iOS devices are all on the same wireless network, so ruling that out as an issue. When I go to the volume button on either iPhone or iPad, and click the volume icon, there is no Chromecast display option for showing lyrics and artwork.

Nothing changed in my setup, the only thing being the update to 1.8.

To add to my OP, I did test casting YouTube to the Chromecast from my iPhone and it works fine. The Chromecast is working fine and is found easily. It only seems Roon can’t find it. Is there something I need to do in the ROC interface to enable Chromecast as a Display device?

Do you see the Chromecast as an available option in the audio section of settings?
It could maybe have got disabled after the update.
Something like this…

While this might be the case, it’s not needed to use a (video) ChromeCast as audio zone in Roon to be able to use it as a display (independent functionality). And the OP already stated that the ChromeCast is not showing up in Settings|Display.

Other users reported to have issues using Google WiFi components in the past. Maybe looking into this discussions might help: https://community.roonlabs.com/search?q=google%20wifi.

It used to show up as an audio device but no longer does. Again, I can cast to it fine via Netflix and YouTube from my iPhone so I know it isn’t an issue of the device not being on the network.

1 Like

Roon I have found is a bit hit and miss with Chromecasts, especially after updates. This has happened to me several times when Roon has updated it won’t see them I ended up having to reboot my entire network and Rock to get them back. Everything else in the house could see them and cast to them but not Roon.

Great to know. I’ll try a full reboot of the network router and Mesh and see if that does the trick. Not a huge nuisance, this issue, just annoying that it used to work fine and now doesn’t.

Hello @Lance_Goler,

Thanks a lot for letting us know of the issue you ran into with your Chromecast and for engaging on the community while we got back to work. Thanks everyone for chiming in :pray:

I was wondering if you have any update to share? :nerd_face:

No update, Roon still not able to see my Chromecast.

1 Like


Hi Rebeka,

A couple of things. When I go to the configuration page on the web for ROCK, I see this under Wireless. That is the name of my Google Mesh network but it adds a bunch of characters to it - my network name is simply “LanceBadassNetwork”. It runs both 2.4ghz and 5ghz bands and uses WPA2 security protocol. Is any of that problematic to find my Chromecast on the network?

Also, when I hit the Scan WiFi Networks button, see attached. It would seem that it should find my network again, unless the reason it says no networks found is because it’s already on the network?

Seems like ultimately this is an issue between ROCK and my wireless network.


Add images

I occasionally have this problem and it’s usually fixed by restarting the Roon Server Software.

Thanks @Lance_Goler for following up and sharing all that insight and screenshots :pray:

I’ve looped in our technical team so they can make more specific suggestions in terms of next steps :pray:

Tried that but didn’t fix the issue. M

1 Like

@beka update is it’s fixed. The issue for anyone reading with the same problem is the Chromecast was not on the same network as Roon. I run a Mesh network and also a 2.4ghz off my ISP’s router. It wasn’t on the mesh, now is so everything working properly. Should’ve realized this initially.


Wow! Thanks so much for sharing that @Lance_Goler :partying_face:

I cannot say how thrilled I am and how grateful that you didn’t give up :nerd_face: