Distortion caused by some Tidal tracks

I’ve encountered a problem streaming a handful of albums from Tidal. My subscription is “premium” (lossy), and I have a slow and unstable DSL internet connection. Roon has always had a harder time streaming from Tidal over this poor connection than other platforms I use, but in a few recent cases when playback is working, high level treble content has overloaded my speakers or amps, causing a crackling distortion.

The problem is repeatable, regardless of playback level, and it does not occur when I stream the same tracks outside of Roon, through an Oppo 103 or my iPhone.

Could Roon be handling the compressed files in a way that causes distortion? All DSP in Roon is disabled. I tried turning on the clipping indicator, but it isn’t triggered when this problem occurs.

Hey @Jesse — Thanks for reaching out to us!

First, may I ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

So we can gain some greater insight into this behavior, please verify the following:

  • Just to confirm, playing local content does not have this issue?
  • Does this happen for all endpoints? If you play to system output of your Core machine does this still occur?
  • When did you first notice this behavior? Was it recent? Have there been any changes to your setup that occurred around the same time?
  • Just to confirm, this happens with the same albums every time? Is there anything different about these albums compared to albums that it doesn’t happen to (iMQA, different sample rates, etc.).
  • Can you confirm that Roon is up to date, along with all of the firmware for your devices?


Hi Dylan – thanks for your reply!

My internet source is a Verizon D-Link router with a wireless extender. Wifi is the only connection available at my endpoints.

I’m running ROCK on an Intel NUC6i5SYH, with music stored locally and streamed from Tidal. My endpoints include an HDMI-connected Anthem receiver, which upmixes to a pair of bookshelf speakers and a three way center channel, a MacBook Pro playing to headphones and built in speakers, and an IQaudIO Pi-DAC+ connected by WiFi over the extender and feeding an integrated amp with a pair of bookshelf speakers. The problem is identical through each of these endpoints.

Here are two albums that exhibit the problem:

https://listen.tidal.com/album/9865179 (Track 5 at 4:36 and 5:30)
https://listen.tidal.com/album/87804598 (Track 5 at 1:43)

Apart from those two albums, I’ve only noticed something like this a couple of other times, when it has been mild enough for me not to give it much thought. These are new (to me) albums, with significant dynamic peaks, and at first I thought the tracks were corrupt or simply too much for my systems to handle.

Local content plays perfectly to all endpoints, and most Tidal content plays without audible problems – when it’s possible to stream from Tidal at all.

I haven’t made any recent changes, and Roon is up to date on all devices.



Hey @Jesse,

Thanks for the details!

I tried playing the two tracks that you mentioned and didn’t notice any distortion myself. So we can better understand why things may be a little different for you, please see the following:

  • Can you try playing directly from TIDAL to one of these endpoints? Do you experience the same distortion?
  • Can you share a screenshot of your signal path when playing one of these tracks in Roon?


Hi @Dylan – thanks for checking.

I just tried again playing one of these tracks to the same stereo system, once streaming from Tidal on an Oppo 103, and once streaming from Tidal through Roon to an IQaudIO Pi-DAC+. Through the Oppo there’s no problem, but I get crackling at the same place in the track when going through Roon. Here’s my signal path:

I removed the album from my library and reimported it with no effect.

Any other thoughts?



@Dylan – I noticed one oddity in that screenshot: the album format appears as “TIDAL FLAC 44.1kHz 16bit 2ch,” but the signal path reads the file as “TIDAL AAC 44.1kHz 24bit 2ch.”

Also, the link to the IQaudIO product manual appears twice, but that is the case even with local files, which play perfectly.

Jesse, the Roon support guys are not on top of their game in this thread, unfortunately. Roon recently implemented >16 bit decoding for lossy compression audio formats. This change has caused distortion issues for a great number of Roon users. As this issue has been reported numerous times, it should have been a nearly automatic identification in this thread. While Roon support has not been very forthcoming on this issue, a fix reportedly is in the works.


Thanks for the info, @Jesse!

With the information you’ve provided, it appears that the issue you are experiencing is the same as the issue reported here:

We currently have a solution in progress for this, but there are also other options available for you. In the thread linked above you will find some information about upgrading FFMPEG. Give that a try and you should see improvement here!

Thanks for your patience here while we confirmed the issue, Jesse, and apologies for the troubles.

Kind regards,

@WiWavelength – thanks for clearing that up.

@Dylan – I appreciate your help.

I’m surprised to learn that this is a general problem that has been going on for at least 25 days. If I had been listening at higher levels, the distortion could have damaged my speakers. I’ll try the FFMPEG upgrade, but I’ll be wary of playing Tidal content through Roon until this issue is definitely fixed.

Can you tell me why Roon changed the way it handles AAC in the first place? Isn’t transparent playback of compressed files straightforward for modern hardware, provided the codecs are supported?



I agree, Jesse. I have been surprised and disappointed at Roon’s outwardly low key response to this 24 bit lossy audio decoding issue. Roon broke something with the update, caused a major fault. The Roon response should have been loud and immediate – a fix or a reversion to the previous 16 bit lossy audio decoding process. And while I am not a frequent lossy audio listener, thus not affected by this issue, Roon does seem to treat lossy audio like a second class citizen. So, that may be why this issue continues to linger quietly in the background.


Hi @Dylan – I updated the ffmpeg file, and the tracks I mentioned now play without audible distortion.

I noticed that you suggested the same fix to another user more recently. This solution only works for users who know about the problem, and even then the behavior does not seem to be well enough understood for us to be sure that it has been eliminated. I agree with AJ that you should revert to an earlier method until the new method is trouble free. If this problem causes equipment damage while you’re investigating, you’re going to have some very unhappy customers. In my case, the problem affected signal peaks, so it only became apparent when it was most likely to be harmful.

Potential damage aside, users should be confident that Roon will play supported formats without degradation.

Thanks for your help.



5 posts were split to a new topic: Distortion during playback for certain albums

@Dylan – I understood from another thread that this issue had been resolved in build 339, but I’ve encountered it again, on the Schubert recording I linked above (https://listen.tidal.com/album/9865179).

@Dylan – can you or @Brian comment on this problem? I updated the FFMPEG file when we first identified the issue in August, and all my devices are running the latest version of Roon, but I have encountered the same distortion again.

Hi @Jesse

Sorry for the lack of response here. We are pretty sure that this issue is fixed–so it is possible that there is some other problem with this recording that just sounds similar.

I am listening to it now, and not hearing any trouble. Is there a particular time position within a particular track that exhibits the problem you’re describing? Do you have any DSP enabled in Roon during playback?

Hey @Jesse,

I wish to offer my sincere apologies for the delayed response here. In additional to what Brian asked above, can you confirm a couple other things as well?

  • Are there any other tracks/albums where you experience this, or is this the only one?
  • If you try listening to the same track that has distortion with another endpoint does the same behavior occur?


Just wanted to confirm, I made it to the end of the Schubert disc without any artifacts.

@Dylan and @Brian – Thank you both for your replies. The issue is with track 5 at 5.32; I haven’t heard it anywhere else since updating the FFMPEG file.

I tried playing this file again and got distortion at a normal listening level and at a much quieter level. Playing the track from Tidal through the analog output of my iPad into the same system I had no problems. However, the distortion does seem to be level dependent, and I didn’t hear it when listening through headphones at another endpoint. It seems like rather than introducing artifacts, Roon is processing the file in a way that makes it harder for my system to handle. Any idea what might be going on? The signal path is NUC6i5SYH running ROCK over HDMI -> Anthem receiver with EQ -> speakers. DSP is disabled in Roon.

Thanks for the info, @Jesse!

I listened to that track at the timestamp mentioned and didn’t encounter this issue, so there may be other factors at play here. I’ve passed this info along to the technical team so they can take a closer look. I’ll be sure to update you when I’ve received their feedback.