Distortion using Ropieee with RPi4 and Cyrus Soundkey

Hi all, I set up Ropieee XL on an RPi4 into a Mojo on my main system a few weeks ago and I was so happy with it that I decided to buy another similar set up for the garage. This is also RPi4 but connected via USB into a Cyrus Soundkey Dac.

Everything seems to run fine but about every 3-5 mins there will be 10 seconds of metallic sounding distortion of the music.

Connections between the core and endpoints are all wifi which, I understand, is not ideal (it’s the only option) but have worked fine for the main system.

Does anyone have any suggestions on software or hardware changes I could make to try and fix?

1 Like

If WiFi is your only option maybe try an external WiFi dongle to improve the data rates. Does it work well closer to your AP?

1 Like

What access points and are you using 2.4 or 5GHz? As the other post mentions try moving your Pi closer and see if that improves things.

If you are running 5GHz you could try manually setting the channel width to 40 or even 80 to eek out a bit more throughput.

1 Like

Can also down sample or 16/48 max if it’s happening with higher rate content.

Before messing about with your WiFi which should not result in distortion just drop outs to the playback , I would suggest take it indoors and hardwire it to see if things improve this will rule out if it’s WiFi. If not then it could be either the DAC has an issue, maybe not well supported in Linux or a USB power issue, but considering its a dac designed to work with a smartphone latter is unlikely.

1 Like

Thank you all so much for your help.

I tried the RPi4/Cyrus on ethernet and the problem still occurs.

I then connected the RPi4 to the chord without issue… so it seems the problem is between the RPi4 and the Cyrus Soundkey (Soundkey fine from laptop usb) .

I found someone had a similar issue on a different forum but with no resolution.


Can anyone suggest any further avenues to try?Or should I get a hat with usb output for the Cyrus?

@spockfish should be able to get some details as he’s the developer and see what the logs are saying. It’s a USB 1 Device so in theory it should work ok.

1 Like

On consideration perhaps getting an IQaudio PiDac+ (one of the few hats available locally) and leaving the Soundkey out of the set up altogether might be a more sensible option.

1 Like

Did you manage to find a solution to this?

I have the exact same issue with an Rpi 4 and Soundkey.

I’d like to find a solution if possible, but I guess I can get a different USB DAC to use that doesn’t have any known issues.

I have had the same issue, wired and wireless. I think the issue is that the Soundkey is not an asynchronous dac. I don’t use it anymore, but I did solve the problem. I noticed that the issue didn’t occur on 96khz tracks, so I upsampled everything to 96khz. In the DSP settings turn on Sample Rate Conversion and set to MAX PCM Rate. I was using an ethernet connection, may not work so well in a wireless setup.


Hi David, no I just replaced it in the configuration with an IQ Audio Dac Hat. It was pretty cheap, sounds great and I’ve had no issues with it.

1 Like

Thanks - trying this now on a wireless setup & seems to work so far.

Much appreciated!

You’re welcome, glad I could be of help.