Do I have to update to 2.0 in order to install legacy?

Roon Core Machine

I have roon 1.8 build 1105 currently installed on Roon Rock.

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I would like to upgrade to 1.8 legacy. I followed the steps in the instructions, created a directory in /Data/ called branches. I downloaded roon_1-8 and put it in the branches directory. I renamed it to roon. I told Rock to reinstall. It did its thing and I was still in version 1105. Do I have to upgrade to version 2.0 first in order to install 1.8 legacy or did I do something wrong?

As far as I understand you do not have to go to 2.0 first.

Perhaps. case is important. So the directory needs to be names branches (all lower case), and the file needs to be renamed roon (again all lower case).

Additionally, sometimes it takes several reinstalls before it clicks.

I have been meticulous about the case and I have tried the process half a dozen times.

  1. I created a folder called branches on my Rock /Data share
  2. I downloaded roon_1-8 which is 12k long.
  3. I copied the file into the branches folder previously created
  4. I renamed the file to roon.
  5. In the interface I selected reinstall.
  6. After a couple of minutes my core was still on build 1105.
    I am left with a 12k roon file in branches.

Hi @Jorge_Espinosa ,

Thanks for the report here. We’ve activated diagnostics for your account and noticed a small issue preventing you from updating. We’ve made a tweak on our update server, can you please try the Reinstall button once more?

Thank you very much. Problem solved.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.