Do I have to upgrade to 1.8? I am worried

I usually like to upgrade weeks after a drop.
Based on the feedback, I think I will wait for 1.8.1

1 Like

I’m in the same boat. I am never an early adapter of hardware or software, including updates. 1.7 will remain viable for the foreseeable future, and I’m in no hurry whatsoever to update to 1.8, but again, that is my habit.

1 Like